Bug 436851 - Unix guide is not viewable
Unix guide is not viewable
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Documentation (Show other bugs)
510
All Linux
low Severity low
: ---
: ---
Assigned To: Jay Dobies
Jeff Browning
: Documentation
Depends On:
Blocks: 456984
  Show dependency treegraph
 
Reported: 2008-03-10 15:29 EDT by James Bowes
Modified: 2013-01-10 04:57 EST (History)
6 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:44:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Bowes 2008-03-10 15:29:49 EDT
This bug is actually twofold:
* the acls on the help index page to show the unix guide don't seem to be correct
* the Unix guide was installed from the rhn-web-docs rpm, which isn't installed
any more.

so either the acl should be fixed and the guide should be added to one of the
current rpms, or the unix link should just be removed altogether.
Comment 1 Clifford Perry 2008-12-17 14:16:47 EST
James - can you give URL's as to where you are seeing this? 

Thanks,
Cliff.
Comment 2 James Bowes 2008-12-18 12:56:26 EST
It's in web's html/help/index.pxt:

<rhn-require acl="user_authenticated(); org_entitlement(rhn_nonlinux)">

I don't think rhn_nonlinux is the actual entitlement we use. About point two, it looks like you guys are now shipping it, so that part's ok.
Comment 3 Clifford Perry 2008-12-18 13:13:38 EST
The .htaccess file has incorrect data within it. These I do not think need to be listed, since the .pdf's are no longer shipped on Satellite. 

html/help/.htaccess 

<Files RHN-unix.pdf>
  AuthType Basic
  PerlModule PXT::ApacheHandler
  PerlModule PXT::ApacheAuth
  PerlAuthenHandler PXT::ApacheAuth

  require acl user_authenticated(); org_entitlement(rhn_nonlinux)
</Files>


<Files rhn-enterprise-urg-en.pdf>
  AuthType Basic
  PerlModule PXT::ApacheHandler
  PerlModule PXT::ApacheAuth
  PerlAuthenHandler PXT::ApacheAuth

  require acl user_authenticated(); org_entitlement(sw_mgr_enterprise)
</Files>
Comment 4 John Ha 2009-02-25 02:27:03 EST
The Unix Guide is now "Chapter 11. Unix Support Guide" in the Satellite Reference Guide:

http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Network_Satellite/5.3.0/html/Reference_Guide/ch-unix-support-guide.html

If that makes any difference.
Comment 5 Jay Dobies 2009-04-21 15:00:48 EDT
commit	b2f426b5c3f208e121e12e0031ce10a3bf2462eb
tree	4e0e871453016d98baf804370acc9e9dcb804564

web/html/help/.htaccess

Removed dead references.
Comment 6 Jay Dobies 2009-04-21 15:02:03 EDT
Vader

commit	e50c226416af3c95523f61f4606ef844b447a370
tree	37ca502dcbf027a5c1b42dc37afb002625d8c78e
Comment 7 Jeff Browning 2009-04-27 16:39:59 EDT
Verified.

One side note... it is Chapter 12, not 11.

Aside from this, the guide itself is there and the links are working.
Comment 8 John Sefler 2009-08-26 10:08:21 EDT
Verified on staged (Satellite-5.3.0-RHEL5-re20090724.0) with updates from Aug 20, 2009

The Unix Support Guide is accessible from satellite for both an authenticated user and when a user has not logged in.

click Admin|Help > Reference Guide > English > 12. UNIX Support Guide

Chapter 12. UNIX Support Guide

https://sun-x4200-01.rhts.bos.redhat.com/rhn/help/reference/en-US/ch-unix-support-guide.jsp

moving to RELEASE_PENDING
Comment 9 Brandon Perkins 2009-09-10 16:44:30 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.