This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 436860 - GDM greeter crashes on any mouse click or enter key
GDM greeter crashes on any mouse click or enter key
Status: CLOSED DUPLICATE of bug 436246
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-10 15:56 EDT by Daniel Berrange
Modified: 2015-01-14 18:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 16:56:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2008-03-10 15:56:00 EDT
Description of problem:
Attempting to login by clicking on my username in the greeter results in the
greeter crashing.

Version-Release number of selected component (if applicable):
gdm-2.21.9-0.2008.03.10.2.fc9.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Click on desired username
2.
3.
  
Actual results:
Crash-o-matic

Expected results:
Login & profit

Additional info:
Program received signal SIGTRAP, Trace/breakpoint trap.
[Switching to Thread 0x2aaaad08c9d0 (LWP 3095)]
IA__g_logv (log_domain=<value optimized out>, log_level=<value optimized out>,
format=<value optimized out>, 
    args1=<value optimized out>) at gmessages.c:503
503               g_private_set (g_log_depth, GUINT_TO_POINTER (depth));
(gdb) bt
#0  IA__g_logv (log_domain=<value optimized out>, log_level=<value optimized
out>, format=<value optimized out>, 
    args1=<value optimized out>) at gmessages.c:503
#1  0x000000329f2412e3 in IA__g_log (log_domain=<value optimized out>,
log_level=<value optimized out>, 
    format=<value optimized out>) at gmessages.c:517
#2  0x000000000041a6e8 in g_cclosure_marshal_VOID__VOID () at gmarshal.c:56
#3  0x000000329fa0b72d in IA__g_closure_invoke (closure=<value optimized out>,
return_value=<value optimized out>, 
    n_param_values=<value optimized out>, param_values=<value optimized out>,
invocation_hint=<value optimized out>)
    at gclosure.c:490
#4  0x000000329fa215f0 in signal_emit_unlocked_R (node=<value optimized out>,
detail=<value optimized out>, 
    instance=<value optimized out>, emission_return=<value optimized out>,
instance_and_params=<value optimized out>)
    at gsignal.c:2440
#5  0x000000329fa22d04 in IA__g_signal_emit_valist (instance=<value optimized
out>, signal_id=<value optimized out>, 
    detail=<value optimized out>, var_args=<value optimized out>) at gsignal.c:2199
#6  0x000000329fa23293 in IA__g_signal_emit (instance=<value optimized out>,
signal_id=<value optimized out>, 
    detail=<value optimized out>) at gsignal.c:2243
#7  0x0000000000412296 in g_cclosure_marshal_VOID__VOID () at gmarshal.c:56
#8  0x0000000000413139 in g_cclosure_marshal_VOID__VOID () at gmarshal.c:56
#9  0x00000032a1e0eccb in dbus_connection_dispatch (connection=<value optimized
out>) at dbus-connection.c:4379
#10 0x00000032a4a09605 in ?? () from /usr/lib64/libdbus-glib-1.so.2
#11 0x000000329f2374eb in IA__g_main_context_dispatch (context=<value optimized
out>) at gmain.c:2065
#12 0x000000329f23accd in g_main_context_iterate (context=<value optimized out>,
block=<value optimized out>, 
    dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:2698
#13 0x000000329f23b1fd in IA__g_main_loop_run (loop=<value optimized out>) at
gmain.c:2906
#14 0x00002aaaaae4f668 in IA__gtk_main () at gtkmain.c:1163
#15 0x000000000040d534 in g_cclosure_marshal_VOID__VOID () at gmarshal.c:56
#16 0x00002aaaaba3b47a in __libc_start_main () from /lib64/libc.so.6
#17 0x000000000040d209 in g_cclosure_marshal_VOID__VOID () at gmarshal.c:56
#18 0x00007fff620c5c78 in ?? ()
#19 0x000000000000001c in ?? ()
#20 0x0000000000000001 in ?? ()
#21 0x00007fff620c7d69 in ?? ()
#22 0x0000000000000000 in ?? ()
Comment 1 Will Woods 2008-03-10 16:28:23 EDT
Check /var/log/gdm/:0.log - does it have a traceback like the one in bug 436834?
Comment 2 jmccann 2008-03-10 16:56:59 EDT

*** This bug has been marked as a duplicate of 436246 ***

Note You need to log in before you can comment on or make changes to this bug.