Bug 43687 - 198.162.32.215 > xxx.xxx.xxx.xxx
198.162.32.215 > xxx.xxx.xxx.xxx
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: tcpdump (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-06 09:09 EDT by Mark Hardiman
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-27 12:39:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Hardiman 2001-06-06 09:09:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT)

Description of problem:
I'm having a problem with tcpdump-3.6.2, libpcap-0.6.2 and RedHat7.1.   I 
am getting two decimal places for the milliseconds instead of the full 
six. I think it is RedHat7.1. that is the problem.
Here is the log (Sanitized):
                                         
198.162.32.215 > xxx.xxx.xxx.xxx
00:03:39.450000 somewhere.on.the.net.1149 > xxx.xxx.xxx.xxx.135: S 
2836809269:2836809269(0) win 16384  (DF)
00:03:42.630000 somewhere.on.the.net.1149 > xxx.xxx.xxx.xxx.135: S 
2836809269:2836809269(0) win 16384  (DF)
00:03:49.200000 somewhere.on.the.net.1149 > xxx.xxx.xxx.xxx.135: S 
2836809269:2836809269(0) win 16384  (DF)
00:04:02.500000 somewhere.on.the.net.1163 > xxx.xxx.xxx.xxx.135: S 
3259847217:3259847217(0) win 16384  (DF)
00:04:05.710000 somewhere.on.the.net.1163 > xxx.xxx.xxx.xxx.135: S 
3259847217:3259847217(0) win 16384  (DF)
00:04:12.280000 somewhere.on.the.net.1163 > xxx.xxx.xxx.xxx.135: S 
3259847217:3259847217(0) win 16384  (DF)
00:04:57.550000 somewhere.on.the.net.1194 > xxx.xxx.xxx.xxx.135: S 
2338289000:2338289000(0) win 16384  (DF)
00:05:00.740000 somewhere.on.the.net.1194 > xxx.xxx.xxx.xxx.135: S 
2338289000:2338289000(0) win 16384  (DF)
00:05:07.300000 somewhere.on.the.net.1194 > xxx.xxx.xxx.xxx.135: S 
2338289000:2338289000(0) win 16384  (DF)
00:05:14.100000 somewhere.on.the.net.1195 > xxx.xxx.xxx.xxx.135: S 
2445288674:2445288674(0) win 16384  (DF)
00:05:17.370000 somewhere.on.the.net.1195 > xxx.xxx.xxx.xxx.135: S 
2445288674:2445288674(0) win 16384  (DF)
00:05:21.590000 somewhere.on.the.net.1196 > xxx.xxx.xxx.xxx.135: S 
3224938981:3224938981(0) win 16384  (DF)
00:05:23.930000 somewhere.on.the.net.1195 > xxx.xxx.xxx.xxx.135: S 
2445288674:2445288674(0) win 16384  (DF)


How reproducible:
Always

Steps to Reproduce:
1.I'm having a problem with tcpdump-3.6.2, libpcap-0.6.2 and RedHat7.1.   
I am getting two decimal places for the milliseconds instead of the full 
six. 
2.
3.
	

Additional info:
Comment 1 Harald Hoyer 2001-07-25 04:50:03 EDT
[harald@faro sysconf]$ sudo /usr/sbin/tcpdump
tcpdump: listening on eth0
10:49:27.255307 ool-18bc4843.dyn.optonline.net.6699 > 
faro.stuttgart.redhat.com.36705: . 618315364:618315888(524) ack 1862990832 win 
46661 <nop,nop,timestamp 599263 59202584>
10:49:27.257049 faro.stuttgart.redhat.com.35349 > 
helsinki.stuttgart.redhat.com.domain:  9043+ PTR? 67.72.188.24.in-addr.arpa. 
(43) (DF)
10:49:27.261102 ool-18bc4843.dyn.optonline.net.6699 > 
faro.stuttgart.redhat.com.36705: P 524:952(428) ack 1 win 46661 
<nop,nop,timestamp 599263 59202584>
10:49:27.261158 faro.stuttgart.redhat.com.36705 > 
ool-18bc4843.dyn.optonline.net.6699: . ack 952 win 17292 <nop,nop,timestamp 
59202623 599263> (DF)
10:49:27.300184 ool-18bc4843.dyn.optonline.net.6699 > 
faro.stuttgart.redhat.com.36705: . 952:1476(524) ack 1 win 46661 
<nop,nop,timestamp 599263 59202587>
10:49:27.307540 ool-18bc4843.dyn.optonline.net.6699 > 
faro.stuttgart.redhat.com.36705: . 1476:2000(524) ack 1 win 46661 
<nop,nop,timestamp 599263 59202587>
10:49:27.307599 faro.stuttgart.redhat.com.36705 > 
ool-18bc4843.dyn.optonline.net.6699: . ack 2000 win 17292 <nop,nop,timestamp 
59202628 599263> (DF)
10:49:27.309985 ool-18bc4843.dyn.optonline.net.6699 > 
faro.stuttgart.redhat.com.36705: . 2000:2524(524) ack 1 win 46661 
<nop,nop,timestamp 599263 59202587>
10:49:27.314108 ool-18bc4843.dyn.optonline.net.6699 > 
faro.stuttgart.redhat.com.36705: . 2524:3048(524) ack 1 win 46661 
<nop,nop,timestamp 599263 59202587>
10:49:27.314139 faro.stuttgart.redhat.com.36705 > 
ool-18bc4843.dyn.optonline.net.6699: . ack 3048 win 17292 <nop,nop,timestamp 
59202629 599263> (DF)
10:49:27.322483 ool-18bc4843.dyn.optonline.net.6699 > 
faro.stuttgart.redhat.com.36705: . 3048:3572(524) ack 1 win 46661 
<nop,nop,timestamp 599263 59202587>
10:49:27.327530 ool-18bc4843.dyn.optonline.net.6699 > 
faro.stuttgart.redhat.com.36705: . 3572:4096(524) ack 1 win 46661 
<nop,nop,timestamp 599263 59202587>
10:49:27.327570 faro.stuttgart.redhat.com.36705 > 
ool-18bc4843.dyn.optonline.net.6699: . ack 4096 win 17292 <nop,nop,timestamp 
59202630 599263> (DF)
Comment 2 Mark Hardiman 2001-07-25 10:03:43 EDT
Current Release of what? (tcpdump,libpcap,RedHat) Because I have the current 
version of Redhat.
Comment 3 Harald Hoyer 2001-07-25 10:13:02 EDT
oups... did I say currentrelease? ... I meant rawhide... ;)
tcpdump-3.6.2-7
Comment 4 Mark Hardiman 2001-07-27 12:39:28 EDT
We pulled down rawhide and the version of tcpdump-3.6.2-7.
It gave an error saying that libcrypto.so.2 is needed by tcpdump-3.6.2-7
So we went to rawhides site and pulled down rawhides libpcap and installed it 
and that did not work. So I try to reload glibc and that did not work.
Whats the easy way to update to rawhide and tcpdump-3.6.2-7 with the versions 
of Redhat 7.1 and tcpdump-3.6.2, libpcap-0.6.2?
Comment 5 Harald Hoyer 2001-07-30 05:04:25 EDT
Download tcpdump-3.6.2-7.src.rpm
# rpm --rebuild tcpdump-3.6.2-7.src.rpm
and install the built tcpdump rpm.

Note You need to log in before you can comment on or make changes to this bug.