Bug 436884 - Crash when clicking Other
Crash when clicking Other
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-10 18:09 EDT by jmccann
Modified: 2015-01-14 18:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 00:37:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jmccann 2008-03-10 18:09:15 EDT
Clicking Other... crashes greeter.  Seeing this in rawhide today.

Mar 10 17:55:43 localhost gdm-simple-greeter[991]: GLib-GObject-CRITICAL:
g_signal_emit_valist: assertion `signal_id > 0' failed#012aborting...



#0  IA__g_logv (log_domain=<value optimized out>, log_level=<value optimized
out>, format=<value optimized out>, 
    args1=<value optimized out>) at gmessages.c:503
#1  0x005e90d6 in IA__g_log (log_domain=Could not find the frame base for
"IA__g_log".
) at gmessages.c:517
#2  0x005e933b in IA__g_return_if_fail_warning (log_domain=Could not find the
frame base for "IA__g_return_if_fail_warning".
) at gmessages.c:532
#3  0x006a9d62 in IA__g_signal_emit_valist (instance=<value optimized out>,
signal_id=<value optimized out>, 
    detail=<value optimized out>, var_args=<value optimized out>) at gsignal.c:2127
#4  0x006aa716 in IA__g_signal_emit (instance=Could not find the frame base for
"IA__g_signal_emit".
) at gsignal.c:2243
#5  0x0805e0ec in on_user_chosen (user_chooser=0x878d020,
login_window=0x8783018) at gdm-greeter-login-window.c:1109
#6  0x006a0044 in IA__g_cclosure_marshal_VOID__VOID (closure=<value optimized
out>, return_value=Could not find the frame base for
"IA__g_cclosure_marshal_VOID__VOID".
) at gmarshal.c:77
#7  0x0069215b in IA__g_closure_invoke (closure=<value optimized out>,
return_value=<value optimized out>, 
    n_param_values=<value optimized out>, param_values=<value optimized out>,
invocation_hint=<value optimized out>)
    at gclosure.c:490
#8  0x006a8b3d in signal_emit_unlocked_R (node=<value optimized out>,
detail=<value optimized out>, 
    instance=<value optimized out>, emission_return=<value optimized out>,
instance_and_params=<value optimized out>)
    at gsignal.c:2440
#9  0x006aa270 in IA__g_signal_emit_valist (instance=<value optimized out>,
signal_id=<value optimized out>, 
    detail=<value optimized out>, var_args=<value optimized out>) at gsignal.c:2199
#10 0x006aa716 in IA__g_signal_emit (instance=Could not find the frame base for
"IA__g_signal_emit".
) at gsignal.c:2243
#11 0x080530f9 in on_animation_done (widget=0x878d020) at gdm-chooser-widget.c:523
#12 0x005de714 in g_source_callback_unref (cb_data=<value optimized out>) at
gmain.c:1186
#13 0x005ded10 in g_source_destroy_internal (source=<value optimized out>,
context=<value optimized out>, 
    have_lock=<value optimized out>) at gmain.c:965

(gdb) frame 5
(gdb) print signals[BEGIN_VERIFICATION]
$2 = 0
Comment 1 jmccann 2008-03-10 18:14:39 EDT
Appears to be this:
http://svn.gnome.org/viewvc/gdm/trunk/gui/simple-greeter/gdm-greeter-login-window.c?r1=5971&r2=5973

Probably due to a faulty git-svn merge.

Fixed upstream now.  I'll roll a new package for rawhide tonight.

Note You need to log in before you can comment on or make changes to this bug.