Bug 436903 - gnome print dialogs don't display cups classes or instances
gnome print dialogs don't display cups classes or instances
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libgnomeprint22 (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Marek Kašík
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-10 21:45 EDT by Ian Mortimer
Modified: 2008-04-17 08:25 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-17 08:25:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Mortimer 2008-03-10 21:45:23 EDT
Description of problem:
cups allows you to group printers into classes for load sharing and redundancy.
   cups also allows you to define printer instances with different options. 
gnome print dialogs don't show classes or instances as printer options either
when choosing a printer or when setting a default printer


Version-Release number of selected component (if applicable):
libgnomeprint22-2.18.2-1.fc8

How reproducible:
Always


Steps to Reproduce:
1. Define a printer class in cups
2. Define some printer instances in cups
3. Open a print dialog from any gnome application (gedit for example).
  
Actual results:
The printer class and the instances aren't shown in the list of available printers.


Expected results:
Classes and instances should be shown in the list of available printers.


Additional info:
A cups printer class can be created from the cups web interface or from
system-config-printer with 1 or more printers as members.  Jobs sent to the
class will go to the first printer available.

A cups instance can easily be created in any user account by adding an enty to
.lpoptions.   For example:

Dest printer3/color ColorModel=CMYK

That would let you print in color to a printer which defaults to black & white.
 From the command line you would use:  lpr -P printer3/color ...

Classes and instances are both very useful on a network with a number of
printers but the only way you can print to them from gnome applications is by
defining a custom print command which is not intuitive for novice linux users.
Comment 1 Marek Kašík 2008-04-03 10:07:32 EDT
Hello Ian,
I'm trying to reproduce this bug, but the Fedora shows me all printers. Could
you post here your /etc/cups/cupsd.conf, /etc/cups/printers.conf,
/etc/classes.conf and the lpoptions file?
Is any printer of those printers local?
Does the dialog show "Generic Postscript" and "Create a PDF document" printers?

  Thank you

    Marek
Comment 2 Ian Mortimer 2008-04-06 21:36:01 EDT
cups is not running on the local host.  It's printing through a network print
server running el4.  The only cups configuration on the local host is to disable
cups (chkconfig cups off) and add a ServerName setting to /etc/cups/client.conf.

the lpoptions file has:

Default ps1
Dest ps1/short sides=two-sided-short-edge
Dest ps1/simplex sides=one-sided
Dest qops1/color ColorModel=CMYK
Dest qops1/slide ColorModel=CMYK sides=one-sided InputSlot=MultiTray MediaType=OHP

lpstat -t shows:

system default destination: ps1
members of class ps1:
        ps1-4300
        ps1-4350
device for ps1-4300: socket://hp4300:9100/
device for ps1-4350: socket://hp4350:9100
device for qops1: lpd://qops1.physics.uq.edu.au/lp
device for qops1/color: lpd://qops1.physics.uq.edu.au/lp
device for qops1/slide: lpd://qops1.physics.uq.edu.au/lp
ps1-4300 accepting requests since Thu 01 Jan 1970 10:00:00 EST
ps1-4350 accepting requests since Thu 01 Jan 1970 10:00:00 EST
qops1 accepting requests since Thu 01 Jan 1970 10:00:00 EST
qops1/color accepting requests since Thu 01 Jan 1970 10:00:00 EST
qops1/slide accepting requests since Thu 01 Jan 1970 10:00:00 EST
printer ps1-4300 is idle.  enabled since Thu 01 Jan 1970 10:00:00 EST
printer ps1-4350 is idle.  enabled since Thu 01 Jan 1970 10:00:00 EST
printer qops1 is idle.  enabled since Thu 01 Jan 1970 10:00:00 EST
printer qops1/color is idle.  enabled since Thu 01 Jan 1970 10:00:00 EST
printer qops1/slide is idle.  enabled since Thu 01 Jan 1970 10:00:00 EST

None of the printers are local.

The dialog shows "Generic Postscript" and "Create a PDF document".

Seems like the problem relates to printing through the el4 print server
(apologies for not mentioning that in the initial report).
Comment 3 Marek Kašík 2008-04-17 07:13:00 EDT
Hello Ian,
this problem is partially caused by old version of cups. The el4 version of cups
doesn't return classes in the list of printers. The newer version of cups
returns classes together with printers in CUPS_GET_PRINTERS request.
The second half of this problem are instances. The libgnomecups doesn't request
instances and we will not implement this feature in libgnomecups.
We will consider this feature in newer versions of printing related software.

  Thank you

    Marek
Comment 4 Marek Kašík 2008-04-17 08:25:05 EDT
Hello,
small correction.
libgnomecups has functions that parse lpoptions, but libgnomeprint22 doesn't use
them.

  Marek

Note You need to log in before you can comment on or make changes to this bug.