Bug 436977 - Java client incompatible with Java version shipped with RHEL-5.1
Java client incompatible with Java version shipped with RHEL-5.1
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-java (Show other bugs)
beta
All Linux
medium Severity low
: 1.3
: ---
Assigned To: messaging-bugs
Kim van der Riet
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-11 09:48 EDT by Subhendu Ghosh
Modified: 2016-10-04 00:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-27 15:08:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Subhendu Ghosh 2008-03-11 09:48:08 EDT
+++ This bug was initially created as a clone of Bug #429907 +++

Description of problem:

Java client/examples don't work on stock RHEL-5.1 because the client requires
Java 1.5 and RHEL-5.1 has Java 1.4.

Version-Release number of selected component (if applicable):

Beta-2

How reproducible:

Try to run the JMS examples according to the tutorial.


--

RHEL 5 Supplementary channels includes Sun Java 1.5 - need to run a test to
confirm that the client and examples work with the JVM from the supplementaries
channel.

JVMs available:
java-1.5.0-sun-*
java-1.5.0-bea-*
java-1.5.0-ibm-*

Update docs to note java-1.5.0 requirement.
Comment 1 Carl Trieloff 2009-02-09 14:19:56 EST
should be fine now with RHEL 5.3
Comment 2 Justin Ross 2011-06-27 15:08:24 EDT
Long since resolved; closing.

Note You need to log in before you can comment on or make changes to this bug.