Bug 436994 - can't talk to libvirtd
can't talk to libvirtd
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
: 437283 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-11 11:54 EDT by Bill Nottingham
Modified: 2014-03-16 23:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 17:35:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2008-03-11 11:54:30 EDT
Description of problem:

Unable to open connection to hypervisor URI 'qemu:///system':
<class 'libvirt.libvirtError'> virConnectOpenAuth() failed Failed to collect
auth credentials
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/connection.py", line 427, in
_open_thread
    None], flags)
  File "/usr/lib64/python2.5/site-packages/libvirt.py", line 94, in openAuth
    if ret is None:raise libvirtError('virConnectOpenAuth() failed')
libvirtError: virConnectOpenAuth() failed Failed to collect auth credentials

Version-Release number of selected component (if applicable):

libvirt-0.4.1-3.fc9.x86_64
virt-manager-0.5.4-1.fc9.x86_64

How reproducible:

Every time
Comment 1 Daniel Berrange 2008-03-11 12:00:29 EDT
Were you running virt-manager as root, or non-root ? Please attach the
$HOME/.virt-manager/virt-manager.log file.
Comment 2 Bill Nottingham 2008-03-11 12:08:22 EDT
As me, but going through consolehelper, so that should be root (that's where the
log file is, in any case.)


[Tue, 11 Mar 2008 12:07:52 virt-manager 29327] INFO (virt-manager:128)
Application startup
[Tue, 11 Mar 2008 12:07:52 virt-manager 29328] DEBUG (engine:74) About to
connect to uris ['qemu:///system']
[Tue, 11 Mar 2008 12:07:52 virt-manager 29328] DEBUG (connection:182) Got
physical device /org/freedesktop/Hal/devices/net_00_1b_77_2f_c6_7a_0
[Tue, 11 Mar 2008 12:07:52 virt-manager 29328] DEBUG (connection:234) Adding net
device wmaster0 00:1b:77:2f:c6:7a /sys/class/net/wmaster0 bridge None
[Tue, 11 Mar 2008 12:07:52 virt-manager 29328] DEBUG (connection:216) Checking
for VLANs on /sys/class/net/wmaster0
[Tue, 11 Mar 2008 12:07:52 virt-manager 29328] DEBUG (connection:182) Got
physical device /org/freedesktop/Hal/devices/net_00_1b_77_2f_c6_7a
[Tue, 11 Mar 2008 12:07:52 virt-manager 29328] DEBUG (connection:234) Adding net
device wlan0 00:1b:77:2f:c6:7a /sys/class/net/wlan0 bridge None
[Tue, 11 Mar 2008 12:07:52 virt-manager 29328] DEBUG (connection:216) Checking
for VLANs on /sys/class/net/wlan0
[Tue, 11 Mar 2008 12:07:52 virt-manager 29328] DEBUG (connection:182) Got
physical device /org/freedesktop/Hal/devices/net_00_15_58_c3_f7_5e
[Tue, 11 Mar 2008 12:07:52 virt-manager 29328] DEBUG (connection:234) Adding net
device eth0 00:15:58:c3:f7:5e /sys/class/net/eth0 bridge None
[Tue, 11 Mar 2008 12:07:52 virt-manager 29328] DEBUG (connection:216) Checking
for VLANs on /sys/class/net/eth0
[Tue, 11 Mar 2008 12:07:54 virt-manager 29328] DEBUG (connection:333) Scheduling
background open thread for qemu:///system
[Tue, 11 Mar 2008 12:07:54 virt-manager 29328] DEBUG (connection:416) Background
thread is running
[Tue, 11 Mar 2008 12:07:54 virt-manager 29328] DEBUG (connection:339) Doing
policykit for org.libvirt.unix.manage
[Tue, 11 Mar 2008 12:07:54 virt-manager 29328] ERROR (connection:412) Failed to
get credentials 'qemu:///system':
<class 'dbus.exceptions.DBusException'>
org.freedesktop.DBus.Error.Spawn.ExecFailed: dbus-launch failed to autolaunch
D-Bus session: No protocol specified
Autolaunch error: X11 initialization failed.

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/connection.py", line 397, in _do_creds
    return self._do_creds_polkit(creds[0][1])
  File "/usr/share/virt-manager/virtManager/connection.py", line 340, in
_do_creds_polkit
    bus = dbus.SessionBus()
  File "/usr/lib/python2.5/site-packages/dbus/_dbus.py", line 217, in __new__
    mainloop=mainloop)
  File "/usr/lib/python2.5/site-packages/dbus/_dbus.py", line 106, in __new__
    bus = BusConnection.__new__(subclass, bus_type, mainloop=mainloop)
  File "/usr/lib/python2.5/site-packages/dbus/bus.py", line 125, in __new__
    bus = cls._new_for_bus(address_or_type, mainloop=mainloop)
DBusException: org.freedesktop.DBus.Error.Spawn.ExecFailed: dbus-launch failed
to autolaunch D-Bus session: No protocol specified
Autolaunch error: X11 initialization failed.


[Tue, 11 Mar 2008 12:07:54 virt-manager 29328] ERROR (connection:440) Unable to
open connection to hypervisor URI 'qemu:///system':
<class 'libvirt.libvirtError'> virConnectOpenAuth() failed Failed to collect
auth credentials
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/connection.py", line 427, in
_open_thread
    None], flags)
  File "/usr/lib64/python2.5/site-packages/libvirt.py", line 94, in openAuth
    if ret is None:raise libvirtError('virConnectOpenAuth() failed')
libvirtError: virConnectOpenAuth() failed Failed to collect auth credentials

[Tue, 11 Mar 2008 12:07:54 virt-manager 29328] DEBUG (connection:444) Background
open thread complete, scheduling notify
[Tue, 11 Mar 2008 12:07:54 virt-manager 29328] DEBUG (connection:453) Notifying
open result
Comment 3 Daniel Berrange 2008-03-11 12:16:17 EDT
Can you re-try and when consolehelper pops up the authentication dialog, select
the 'Run unprivileged' button so it runs as your normal user account instead of
root.

It looks like it simply doesn't get the DBus session bus connection when running
as root. Should be simple enough to fix once you confirm it runs OK when
unprivileged...
Comment 4 Bill Nottingham 2008-03-11 12:20:44 EDT
Seems to work as unprivileged. (And then asks for auth via PK.)
Comment 5 Daniel Berrange 2008-03-13 13:56:32 EDT
*** Bug 437283 has been marked as a duplicate of this bug. ***
Comment 6 Daniel Berrange 2008-03-13 17:35:50 EDT
Fixed in virt-manager-0.5.4-2.fc9

Note You need to log in before you can comment on or make changes to this bug.