This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 43701 - cdparanoia fails to identify an atapi cd-rw using scsi emulation
cdparanoia fails to identify an atapi cd-rw using scsi emulation
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: cdparanoia-III (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-06 12:53 EDT by Leo Lopes
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-06 12:53:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leo Lopes 2001-06-06 12:53:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
cdparanoia starts, checks /dev/cdrom, then /dev/scd0, but reports no
generic SCSI device found.

How reproducible:
Always

Steps to Reproduce:
1.run cdparanoia -B -v
	

Actual Results:  [leo@localhost br]$ cdparanoia -B -v
cdparanoia III release 9.7 (December 13, 1999)
(C) 1999 Monty <monty@xiph.org> and Xiphophorus

Report bugs to paranoia@xiph.org
http://www.xiph.org/paranoia/

Checking /dev/cdrom for cdrom...
        Testing /dev/cdrom for cooked ioctl() interface
                /dev/scd0 is not a cooked ioctl CDROM.
        Testing /dev/cdrom for SCSI interface
                No generic SCSI device found to match CDROM device
/dev/scd0


Expected Results:  It should have started ripping the CD:

[leo@localhost br]$ cdparanoia -B -v
cdparanoia III release 9.7 (December 13, 1999)
(C) 1999 Monty <monty@xiph.org> and Xiphophorus

Report bugs to paranoia@xiph.org
http://www.xiph.org/paranoia/

Checking /dev/cdrom for cdrom...
        Testing /dev/cdrom for cooked ioctl() interface
                /dev/scd0 is not a cooked ioctl CDROM.
        Testing /dev/cdrom for SCSI interface
                generic device: /dev/sg0
                ioctl device: /dev/scd0
                CDROM sensed: ATAPI CD-R/RW CRW6206A 1.2A 


Additional info:

The problem is that the RH7.1 installer does not create the /dev/sg*
devices, and does not load the sg module. To solve the problem, go to /dev,
run ./MAKEDEV sg, then go to rc.sysinit, find the reference to modprobe
ide-cd, copy that line and replace ide-cd with sg.
Comment 1 Leo Lopes 2001-06-06 12:57:01 EDT
Also, unless root is the only user to run cdparanoia, the /dev/sg? device needs
to have read and write permissions for all.

Note You need to log in before you can comment on or make changes to this bug.