Bug 437013 - ipmicmd crashed with Segmentation fault
ipmicmd crashed with Segmentation fault
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: OpenIPMI (Show other bugs)
5.1
s390x Linux
medium Severity medium
: rc
: ---
Assigned To: Jan Safranek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-11 12:59 EDT by Milos Malik
Modified: 2009-09-02 05:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:59:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2008-03-11 12:59:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; cs-CZ; rv:1.8.1.12) Gecko/20080208 Fedora/2.0.0.12-1.fc8 Firefox/2.0.0.12

Description of problem:
When I was testing ipmicmd on s390x-5s-2-v1.z900.redhat.com it always crashed.

Version-Release number of selected component (if applicable):
OpenIPMI-2.0.6-6

How reproducible:
Always


Steps to Reproduce:
1. ipmicmd -k "sdr" lan 10.10.1.145 623 md5 admin root changeme


Actual Results:
It crashed almost immediately with the message "Segmentation fault".

Expected Results:
It will run without the message "Segmentation fault".

Additional info:
Comment 1 Jan Safranek 2009-03-05 06:09:00 EST
Core dump:

(gdb) bt
#0  ipmi_lanp_setup_con (parms=<value optimized out>, num_parms=<value optimized out>, handlers=<value optimized out>, user_data=<value optimized out>, 
    new_con=<value optimized out>) at ipmi_lan.c:1368
#1  0x00000041eeeb80ee in lan_connect_args (args=<value optimized out>, handlers=<value optimized out>, user_data=<value optimized out>, 
    con=<value optimized out>) at ipmi_lan.c:5965
#2  0x00000000800036b4 in main (argc=10, argv=0x3ffff87a8c8) at ipmicmd.c:805
Comment 3 Jan Safranek 2009-03-05 08:21:47 EST
Just a note: from some reason, the bug is reproducible only on the aforementioned machine, I was not able to reproduce it on s390 from RHTS.
Comment 9 errata-xmlrpc 2009-09-02 05:59:06 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1312.html

Note You need to log in before you can comment on or make changes to this bug.