Bug 437017 - Satellite suffers from severe performance degradation during System Group changes
Summary: Satellite suffers from severe performance degradation during System Group cha...
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other   
(Show other bugs)
Version: 410
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Shannon Hughes
QA Contact: Brandon Perkins
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-11 17:35 UTC by James Puellmann
Modified: 2009-05-28 20:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-23 21:37:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sar data captured during removal of one, and then two, hosts from a single System Group (1.03 MB, application/octet-stream)
2008-03-11 17:35 UTC, James Puellmann
no flags Details

Description James Puellmann 2008-03-11 17:35:45 UTC
Description of problem:

Removing a host from a System Group via the RHN Satellite web interface
generates severely high loads and very high %iowait due to excessive disk
writes. Removal of a single host from a System Group takes 5 minutes. Removal of
N hosts takes 5N minutes.

Version-Release number of selected component (if applicable):

RHN release 4.1.5

How reproducible:

Every time.

Steps to Reproduce:
1. Remove host from System Group
2.
3.
  
Actual results:

5 minutes of high load and %iowait while system writes copious amounts of data
to disk.

Expected results:

Low load, low disk usage, quick return time.

Additional info:

sar data is attached.
For reference, a single host was removed from the USWHWK6 System Group at
16:33:01. Time to completion: 5+ minutes. At 16:41:05, two hosts were removed
from the same System Group. Time to completion: 9+ minutes.

Note spike in loadavg, %iowait, block device IO during executions.

Comment 1 James Puellmann 2008-03-11 17:35:45 UTC
Created attachment 297647 [details]
sar data captured during removal of one, and then two, hosts from a single System Group

Comment 3 James Puellmann 2008-03-11 17:46:27 UTC
More info on this Satellite server:

1594 subscribed hosts - all with Management Entitlement. A couple (RHN Proxies)
with Provisioning.
193 System Groups
22 Software Channels, 10 of these are custom. the rest standard Red Hat channels.
Some of the custom channels are Clones. Some are not.
403 managed packages (uploaded via rhnpush).
No config channels defined.

Comment 4 James Puellmann 2008-03-11 18:10:41 UTC
Even more info on satellite server. I'm not sure if these numbers are high or
low or not:

[user@host ~]$ sudo find /data01/satellite/ -type f | wc -l
40112
[user@host ~]$ sudo find /data01/satellite/ -type l | wc -l
26823
[user@host ~]$ sudo find /data01/satellite/ -type d | wc -l
60753

Comment 7 Clifford Perry 2009-03-23 18:35:42 UTC
Hi there, 
has there been a support request opened for this to track with? 
Right now there is no customer associated ticket aligned to this bug report, nor the initial investigation performed by our Support Engineering Group to gain replication and understanding of the bug being reported. 

Thanks,
Cliff.

Comment 9 Jon Stanley 2009-03-23 21:37:08 UTC
Hey Cliff - 

Not sure if there's been a case opened or not. Considering that the report is a year old at this point, we've upgraded to Sat 5.1, and I don't think we've seen this problem, it's fairly safe to close this BZ.

-Jon


Note You need to log in before you can comment on or make changes to this bug.