Bug 437053 - factorial[31471]: segfault at 00020b41 eip 0804adc8 esp bffa87d0 error 4
factorial[31471]: segfault at 00020b41 eip 0804adc8 esp bffa87d0 error 4
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mysql (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Tom Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-11 18:02 EDT by Robert Scheck
Modified: 2013-07-02 23:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-27 16:45:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2008-03-11 18:02:50 EDT
Description of problem:
A rebuild of MySQL in Rawhide (outside of mock) causes the following 
segmentation faults to me which looks *very* strange, because this is
make test/check or so?!

Mar 10 22:50:52 tux kernel: factorial[31459]: segfault at 00020b41 eip 0804adc8
esp bf97e190 error 4
Mar 10 22:50:52 tux kernel: factorial[31463]: segfault at 00020b41 eip 0804adc8
esp bfca64c0 error 4
Mar 10 22:50:52 tux kernel: factorial[31471]: segfault at 00020b41 eip 0804adc8
esp bffa87d0 error 4
Mar 10 22:50:52 tux kernel: factorial[31478]: segfault at 00020b41 eip 0804adc8
esp bff937b0 error 4
Mar 10 22:50:52 tux kernel: factorial[31485]: segfault at 00020b41 eip 0804adc8
esp bfb73b80 error 4

Version-Release number of selected component (if applicable):
mysql-5.0.51a-1

How reproducible:
Everytime, see above.

Actual results:
Segmentation fault during package rebuild

Expected results:
No segmentation fault during package rebuild

Additional info:
IMHO this bug report is somehow related with my bug #427707.
Comment 1 Tom Lane 2008-03-11 20:20:08 EDT
Interesting.  I had seen those messages in my own machine's logs, but failed to connect them with building mysql.

The problem appears to be that by default mysql builds everything (in particular libmysys.a) with -DDBUG_OFF, which means that dbug can't 
possibly work, and yet the build sequence tries to use dbug anyway as part of an example program that is run to provide sample output for use 
in the dbug manual.  Since this manual isn't actually installed, the failure has zero effect on the resulting package.  I suppose we could patch 
the Makefile to not bother building the manual, but it barely seems worth it.

The "| cat" hacks in the makefile commands that invoke the sample program have no apparent functional use.  I suspect they are there to 
prevent make from noticing the program failure, which means that somebody at mysql AB already kluged around this in a very obscure way ...

Anyway, I'm afraid you're out of luck if you hoped this would lead to solving any other problems.  It certainly isn't a blocker.
Comment 2 Bug Zapper 2008-05-14 01:57:27 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Robert Scheck 2008-07-27 10:39:13 EDT
Ping?
Comment 4 Tom Lane 2008-07-27 16:45:36 EDT
Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.