Bug 437119 - up2date fails to register even though I have available subscriptions / entitlements
up2date fails to register even though I have available subscriptions / entitl...
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
ia64 Linux
low Severity high
: rc
: ---
Assigned To: Pradeep Kilambi
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-12 11:10 EDT by Jason Clawson
Modified: 2008-07-22 12:17 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-22 12:17:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Clawson 2008-03-12 11:10:05 EDT
Description of problem:

Firstly, I have an active subscription.  I have 3 available entitlements using 0
of them.  My up2date recently stopped functioning saying it didn't have an
available channel.  I logged on to RHN and found that I didnt' have a base
channel to select from in the drop down.  I deleted the system from RHN and
tried to re-register my system using up2date --register hoping it would fix the
channel select problem.

I get this error:

                    Problem registering system:                     â
                  â                                                 â
                  â Error Class Code: 70                            â
                  â Error Class Info:                               â
                  â      All available subscriptions for the        â
                  â requested channel have been exhausted.          â
                  â      Please contact a Red Hat Network Sales     â
                  â associate.                                      â
                  â Explanation:                                    â
                  â      An error has occurred while processing     â
                  â your request. If this problem                   â
                  â      persists please enter a bug report at      â
                  â bugzilla.redhat.com.                            â
                  â      If you choose to submit the bug report,    â
                  â please be sure to include                       â
                  â      details of what you were trying to do      â
                  â when this error occurred and                    â
                  â      details on how to reproduce this problem. 

This isn't true.  I have an available subscription, its not expired, and
available entitlements and nothing is in use.  This is my only Redhat system. 
My subscription is for this system only.  I have no systems on my RHN profile.

I am not sure what is going on.  I have to admit I am a little confused about
the licensing scheme.  But, from what I can gather, this looks like a bug. 
Nothing is expired, nothing is in use... so... this should work.
Comment 1 Clifford Perry 2008-07-22 12:17:26 EDT
Please contact Red Hat Support for assistance. 

Regards,
Clifford. 

Note You need to log in before you can comment on or make changes to this bug.