Bug 437154 - Rebase sanitycheck reports should be a bugzilla admin function
Rebase sanitycheck reports should be a bugzilla admin function
Status: CLOSED WONTFIX
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.6
All Linux
medium Severity low (vote)
: ---
: ---
Assigned To: Simon Green
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-12 13:24 EDT by Noura El hawary
Modified: 2014-10-12 18:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 00:11:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noura El hawary 2008-03-12 13:24:23 EDT
whenever a fix is made to bugzilla database from errors reported by the
sanitycheck reports a diff file will be sent daily/weekly that includes those
fixes. this creates unnecessary emails so we request from sys admins to delete
the original sanitycheck reports to get rid of the diff emails. 

deleting those sanitycheck files under data/sanitycheck should be a bugzilla
admin function not a sys admin function.

My proposed solution for this would be:
maybe we can add to the sanitcheck.pl script , that if the diff file is not
empty then after emailing it to bugzilla-owner , unlink the .orig file under
data/sanitycheck. not sure if this would be a quite a good solution as we might
need to look at those .orig file before we delete them and get new ones? maybe
we can email it along with the diff before deleteing it!

noura
Comment 1 David Lawrence 2008-03-12 13:32:20 EDT
Probably should be an additional argument to the sanitycheck.cgi UI similar to
the params that can be passed in to rebuild keyword cache, etc.

https://bugzilla.redhat.com/sanitycheck.cgi?rebasereports=1

or something similar.
Comment 2 Noura El hawary 2008-03-12 21:51:20 EDT
(In reply to comment #1)
> Probably should be an additional argument to the sanitycheck.cgi UI similar to
> the params that can be passed in to rebuild keyword cache, etc.
> 
> https://bugzilla.redhat.com/sanitycheck.cgi?rebasereports=1
> 
> or something similar.

Dave, We are talking about the sanitycheck.pl in RHBZ_2.18,, not sure if we are
going to replace it with sanitycheck.cgi in 3.2 or it will still be used when we
upgrade. as for the current RHBZ_2.18  I think it will be a good idea to pass
argument to delete the files we don't want under data/sanitycheck, but we will
have to be able to run the script ourselves to pass it this argument whenever we
want to delete the files , so can we run the sanitycheck.pl script or sys admin
will also have to do it? 

Noura 
Comment 3 David Lawrence 2008-03-12 22:57:28 EDT
The reason I mentioned the cgi over the command line script is that the cgi is
our only interface into the sanitycheck code on the live bugzilla. We can't set
any param values due to the data/params file being managed by cfengine. And having
sysadmins run the sanitycheck.pl with a command line option to rebase the
reports doesn't really save us much over just having them remove the
data/sanitycheck/* files. sanitycheck.cgi still exists in 3.2 as well so we can
port the option over to it at the appropriate time.

Dave
Comment 4 David Lawrence 2008-09-16 12:56:02 EDT
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.
Comment 5 David Lawrence 2010-01-15 12:33:11 EST
Red Hat Bugzilla is now using version 3.4 of the Bugzilla codebase and
therefore this feature will need to be implemented against the new release.
Updating bug version to 3.2.
Comment 6 David Lawrence 2010-08-25 17:43:40 EDT
Red Hat has now upgraded to Bugzilla 3.6 and this bug will now be reassigned to that version. It would be helpful to the Bugzilla Development Team if this bug is verified to still be an issue with the latest version. If it is no longer an issue, then feel free to close, otherwise please comment that it is still a problem and we will try to address the issue as soon as we can.

Thanks
Bugzilla Development Team
Comment 8 Simon Green 2012-06-19 00:11:15 EDT
Haven't heard any noise for this bug since it was created, and Noura has now left Red Hat.

  -- simon

Note You need to log in before you can comment on or make changes to this bug.