Bug 437213 - gnome-sudoku halts on startup: Generate more puzzles....
gnome-sudoku halts on startup: Generate more puzzles....
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-games (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-12 18:18 EDT by Tom London
Modified: 2008-03-15 04:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-15 04:35:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 522493 None None None Never

  None (edit)
Description Tom London 2008-03-12 18:18:29 EDT
Description of problem:
Running gnome-sudoku get the message below, and an immediate exit.

Not quite sure how to recover......

[tbl@localhost puzzles]$ gnome-sudoku
WARNING: Not able to provide 1 puzzles in levels ['very hard']
WARNING: Generate more puzzles if you really need this many puzzles!
Traceback (most recent call last):
  File "/usr/bin/gnome-sudoku", line 58, in <module>
    start_game()
  File "/usr/lib/python2.5/site-packages/gnome_sudoku/gnome_sudoku.py", line 21,
in start_game
    main.start_game()
  File "/usr/lib/python2.5/site-packages/gnome_sudoku/main.py", line 1039, in
start_game
    u = UI()
  File "/usr/lib/python2.5/site-packages/gnome_sudoku/main.py", line 200, in
__init__
    if self.select_game():
  File "/usr/lib/python2.5/site-packages/gnome_sudoku/main.py", line 64, in _
    ret = fun(ui,*args,**kwargs)
  File "/usr/lib/python2.5/site-packages/gnome_sudoku/main.py", line 214, in
select_game
    choice =
game_selector.NewOrSavedGameSelector().run_swallowed_dialog(self.swallower)
  File "/usr/lib/python2.5/site-packages/gnome_sudoku/game_selector.py", line
177, in run_swallowed_dialog
    self.setup_dialog()
  File "/usr/lib/python2.5/site-packages/gnome_sudoku/game_selector.py", line
71, in setup_dialog
    self.make_new_game_model()
  File "/usr/lib/python2.5/site-packages/gnome_sudoku/game_selector.py", line
105, in make_new_game_model
    )[0]
IndexError: list index out of range
[tbl@localhost puzzles]$ 



Version-Release number of selected component (if applicable):
gnome-games-2.22.0-1.fc9.i386

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Hans de Goede 2008-03-14 14:42:26 EDT
Hmm,

Works fine for me. Maybe one of the level files got trunkated during upgrade due
to a full disk?

What does: "rpm --verify gnome-games" say?
Comment 2 Tom London 2008-03-14 14:51:43 EDT
Nothing:

[root@localhost ~]# rpm --verify gnome-games
[root@localhost ~]# 

I play quite a bit....

I do remember something on the main pull down that causes it to "generate more
games" of the desired level. I'm guessing its asking me to do this, but it
terminates before I get the chance.

Comment 3 Tom London 2008-03-14 14:55:30 EDT
I "got back in" by renaming ~/.gnome2/gnome-sudoku to ~/.gnome2/gnome-sudoku.old

Program came up in the "New Game" window.

I used the "Tools" menu to manually generate new puzzles.

I typically select the "Very Hard" category; could it be an issue of exhausting
the cached number of such?
Comment 4 Hans de Goede 2008-03-14 15:45:12 EDT
(In reply to comment #3)
> I "got back in" by renaming ~/.gnome2/gnome-sudoku to ~/.gnome2/gnome-sudoku.old
> 
> Program came up in the "New Game" window.
> 
> I used the "Tools" menu to manually generate new puzzles.
> 
> I typically select the "Very Hard" category; could it be an issue of exhausting
> the cached number of such?

That sounds like whats happening to me, yes.

Can you please file this upstream (with what we know think is the cause added):
http://bugzilla.gnome.org/enter_bug.cgi?product=gnome-games

Thanks!
Comment 5 Tom London 2008-03-14 16:01:33 EDT
Done: http://bugzilla.gnome.org/show_bug.cgi?id=522493
Comment 6 Hans de Goede 2008-03-15 04:35:36 EDT
(In reply to comment #5)
> Done: http://bugzilla.gnome.org/show_bug.cgi?id=522493

Thanks,

Closing this one then, as I believe this is best handled/fixed upstream.

Note You need to log in before you can comment on or make changes to this bug.