Bug 437226 - reving gcc-c++ deletes all packages (everyting)
reving gcc-c++ deletes all packages (everyting)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
8
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-12 21:12 EDT by shashi
Modified: 2008-03-13 17:28 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 02:50:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shashi 2008-03-12 21:12:11 EDT
Description of problem:
I was using eclipse cdt, got an exception no .eh_frame_hdr table will be 
created. I found that that is a bug in gcc 4.1.xx, decided to install gcc 4.3, 
I tried yum update by enabling development repository. I coudn't success. I 
downloaded gcc 4.3 and installed. later I realized that I need gcc-c++ also, 
tried to install gcc-c++4.3 , gcc-c++-devel but it didn't let me install as 
4.1.xx is present. so I thought of removing 4.1.xx. did the same thing from 
add remove packages, it showed me some dependencies, I thought its ok. clicked 
ok. then after some time I saw it is removing everyting.... After some time it 
removed everything (yes entire gnome) from my linux......

Tried booting... thats it I lost everyting... I can't even boot into linux... 
This is real dangerous... Just tired to remove some development packages from 
linux...... 

Version-Release number of selected component (if applicable):
Fedora 8 i386.

How reproducible:
Just try to remoev gcc (esp. gcc-c++4.1.xx , gcc-c++-devel) .

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jakub Jelinek 2008-03-13 02:50:10 EDT
You can't mix F8 with some rawhide packages, either you have F8 installed, or F9
beta/rawhide.  There are many dependencies on the 4.1.x packages in F8, the
4.3.0 packages aren't meant for F8.  This is an admin error, nothing else. 
Guess you need to reinstall.
Comment 2 shashi 2008-03-13 17:16:42 EDT
Yes I did reinstall, but my point is I just changed the compilor I didn't 
touch any binaries. Why do we have to have that dependency, I don't think the 
OS and the user should share same compiler. 
I am just not comfortable with sharing the compiler with my OS. Can we create 
shared libraris and just not depend on the compiler any more or keep a 
different compiler for OS and development? 
Can't we just create shared libraries which doesn't dependent on the compiler 
anymore?
Comment 3 shashi 2008-03-13 17:28:18 EDT
More over the OS is all about binaries, what is the role of a compiler? You 
might say without a compiler you can't update packages, I am fine with that 
but I don't want a total crash. If you say it is critical then don't let the 
user to remove it. Why I am so conceren is that I lost all my code just 
because of one stupid bug in the compiler. It took me a whole day to recover 
my data and reinstall OS.

Note You need to log in before you can comment on or make changes to this bug.