Bug 437235 - X segfaults on screen saver activation
Summary: X segfaults on screen saver activation
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-13 03:16 UTC by David G. Mackay
Modified: 2018-04-11 10:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 15:47:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X log (19.62 KB, text/plain)
2008-03-13 03:16 UTC, David G. Mackay
no flags Details

Description David G. Mackay 2008-03-13 03:16:54 UTC
Description of problem:
X server segfaults when the screensaver starts

Version-Release number of selected component (if applicable):
X.Org X Server 1.4.99.901 (1.5.0 RC 1)

How reproducible:
Always

Steps to Reproduce:
1.Allow screen saver to activate or select System->Preferences->Look and
Feel->Screensaver
  
Actual results:
X server segfaults and display shows X login screen

Expected results:


Additional info:
I have a core dump (about 1.7M bzipped that I can make available via sftp.

Comment 1 David G. Mackay 2008-03-13 03:16:54 UTC
Created attachment 297887 [details]
X log

Comment 2 Matěj Cepl 2008-03-13 06:56:50 UTC
(In reply to comment #0)
> I have a core dump (about 1.7M bzipped that I can make available via sftp.

Core dump of what?

Was it M as megabytes? Than just go ahead and attach it here, please? (we don't
have that tight limits on the size of attachments). However, then please provide
exact package versions of xorg-x11-server-Xorg and xorg-x11-drv-vm*

Thank you

Comment 3 David G. Mackay 2008-03-13 14:02:52 UTC
I tried attaching the core dump, and the commit timed out.

On a different note, I just installed a new batch of updates, and the problem
has gone away.


Comment 4 Matěj Cepl 2008-03-13 15:47:30 UTC
OK, so it should settle it. Thanks for letting us know.


Note You need to log in before you can comment on or make changes to this bug.