Bug 437243 - Trying to install HP P1006 on a linksys psus and have been getting this error all day
Trying to install HP P1006 on a linksys psus and have been getting this error...
Status: CLOSED DUPLICATE of bug 437266
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
7
i686 Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-13 01:00 EDT by Jeff Smith
Modified: 2008-03-13 06:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 06:09:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Smith 2008-03-13 01:00:37 EDT
Description of problem:
SELinux is preventing sh (cupsd_t) "execute_no_trans" to
/usr/lib/cups/driver/drv (lib_t).


Version-Release number of selected component (if applicable):


How reproducible:
Try to install the printer on linksys psus ipp or direct jet

Steps to Reproduce:
1.Use "Printing" under system->Administration
2.Add new printer
3.add to HP direct jet or IPP
  
Actual results:


Expected results:
to connect to printer or at least not generate SELinux denials.


Additional info:
Source Context:  system_u:system_r:cupsd_t:SystemLow-SystemHighTarget
Context:  system_u:object_r:lib_tTarget Objects:  /usr/lib/cups/driver/drv [
file ]Affected RPM Packages:  cupsddk-drivers-1.2.3-1.fc7 [target]Policy
RPM:  selinux-policy-2.6.4-70.fc7Selinux Enabled:  TruePolicy Type:  targetedMLS
Enabled:  TrueEnforcing Mode:  EnforcingPlugin Name:  plugins.catchall_fileHost
Name:  localhost.localdomainPlatform:  Linux localhost.localdomain
2.6.23.15-80.fc7 #1 SMP Sun Feb 10 17:29:10 EST 2008 i686 athlonAlert
Count:  10First Seen:  Wed 12 Mar 2008 03:41:36 PM PDTLast Seen:  Wed 12 Mar
2008 09:18:48 PM PDTLocal ID:  50973232-3fa0-4afc-bd44-8184f73e6789Line
Numbers:  Raw Audit Messages :avc: denied { execute_no_trans } for comm="sh"
dev=dm-0 egid=7 euid=4 exe="/bin/bash" exit=-13 fsgid=7 fsuid=4 gid=7 items=0
path="/usr/lib/cups/driver/drv" pid=3831
scontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 sgid=7
subj=system_u:system_r:cupsd_t:s0-s0:c0.c1023 suid=4 tclass=file
tcontext=system_u:object_r:lib_t:s0 tty=(none) uid=4
Comment 1 Tim Waugh 2008-03-13 06:09:44 EDT
'chcon -t bin_t /usr/lib/cups/driver/drv' will work around this.

*** This bug has been marked as a duplicate of 437266 ***

Note You need to log in before you can comment on or make changes to this bug.