Bug 437250 - eject will unmount partitions on non-ejectable device and ends with an error
eject will unmount partitions on non-ejectable device and ends with an error
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: eject (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Michal Luscon
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-13 04:35 EDT by Zdenek Prikryl
Modified: 2013-03-14 13:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-14 08:43:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backport for el5 (4.53 KB, patch)
2010-04-14 09:28 EDT, Kamil Dudka
no flags Details | Diff

  None (edit)
Description Zdenek Prikryl 2008-03-13 04:35:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; cs-CZ; rv:1.8.1.12) Gecko/20080208 Fedora/2.0.0.12-1.fc8 Firefox/2.0.0.12

Description of problem:
Eject unmounts partitions on non-ejectable device, then tries to eject this device and ends with error. But partitions stays unmounted. Eject should not unmount partitions on this kind of devices.

Version-Release number of selected component (if applicable):
eject-2.1.5-4.2.el5

How reproducible:
Always


Steps to Reproduce:
Example: /dev/sda2 is mounted on /boot. Run as an unprivileged user:

[james@harmony ~]$ mount
/dev/mapper/VolGroup00-LogVol00 on / type ext3 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
/dev/sda2 on /boot type ext3 (rw)
/dev/sdb1 on /media/EXT3414G001 type ext3 (rw,nosuid,nodev,uhelper=hal)
/dev/sdb2 on /media/NTFS085G001 type fuseblk
(rw,nosuid,nodev,allow_other,blksize=4096)
[james@harmony ~]$ eject /dev/sda
[james@harmony ~]$ mount
/dev/mapper/VolGroup00-LogVol00 on / type ext3 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
/dev/sdb1 on /media/EXT3414G001 type ext3 (rw,nosuid,nodev,uhelper=hal)
/dev/sdb2 on /media/NTFS085G001 type fuseblk
(rw,nosuid,nodev,allow_other,blksize=4096)

Actual Results:
/boot partition is unmounted

Expected Results:
eject should tell you, that sda is not ejectable device

Additional info:
Fixed in Fedora.
Comment 1 RHEL Product and Program Management 2008-07-21 19:04:57 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 3 Kamil Dudka 2010-03-26 11:10:18 EDT
eject-2.1.5-umount.patch from Fedora (bug 437362) seems to solve the problem
Comment 4 Kamil Dudka 2010-04-14 09:28:15 EDT
Created attachment 406510 [details]
backport for el5
Comment 6 RHEL Product and Program Management 2010-08-09 14:44:38 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 7 RHEL Product and Program Management 2011-05-31 09:50:37 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 8 RHEL Product and Program Management 2011-09-22 20:21:30 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 9 Michal Luscon 2013-03-14 13:05:10 EDT
RHEL-5.10 (the next RHEL-5 minor release) is going to be the first
production phase 2 [1] release of RHEL-5. Since phase 2 we'll be
addressing only security and critical issues.
This one issue is fixed in RHEL-6 therefore I am closing the bug as
NEXTRELEASE.

[1] https://access.redhat.com/support/policy/updates/errata/

Note You need to log in before you can comment on or make changes to this bug.