Bug 437262 - KDM theme not available and not working
KDM theme not available and not working
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdmtheme (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Chitlesh GOORAH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-13 05:57 EDT by Th0ma7
Modified: 2008-03-14 06:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-14 06:16:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Th0ma7 2008-03-13 05:57:23 EDT
Description of problem:
KDM themes are not available.  This means that in the KDM administration window
only the "flower" theme is available (? named bluecircle ??? ain't sure)
although all fedora-kdm-themes are installed.

I tried to manually edit the kdmrc to point to any of the fedora kdm themes but
KDM popups with a warning that it cannot dig thrue the xyz directory (although
it exists with a theme.

note that old fedora kdm themes are located under /usr/share/apps/kdm/themes
while the only one that works (flower) is located under
/usr/share/kde4/apps/kdm/themes/
Comment 1 Chitlesh GOORAH 2008-03-13 06:44:39 EDT
The kdmtheme package is no longer present for KDE4 on rawhide, because its
features are among kde4 apps.

Thus this bug is related to KDE4 apps, Ill contact the appropriate developer to
provide more themes on rawhide.
Comment 2 Kevin Kofler 2008-03-14 06:16:48 EDT
KDE 4 KDM already includes theme configuration, making kdmtheme redundant. But 
KDE 3 KDM themes are _not_ compatible with KDE 4 KDM, so you can only load 
themes which have been designed for the new version.
Comment 3 Th0ma7 2008-03-14 06:35:49 EDT
well then, since I don't have any KDE3 components installed on my system I don't
have any themes available for KDE4 with the default Fedora look & style?  I'm
then stuck with the Circles theme and that's it?
Comment 4 Kevin Kofler 2008-03-14 06:44:14 EDT
Yes. We expect to have a KDE 4 KDM version of the Fedora 9 theme ready for the 
release, crossing fingers...

This is the Fedora 9 theme:
http://fedoraproject.org/wiki/Artwork/F9Themes/Waves/Round3Final

Unfortunately, they apparently don't have a GDM theme ready which we could 
adapt.
Comment 5 Kevin Kofler 2008-03-14 06:45:43 EDT
Oh, and porting the old themes (Bluecurve, Fedora DNA, Fedora Flying High and 
Fedora Infinity) is also something which ideally should get done.

Note You need to log in before you can comment on or make changes to this bug.