Bug 437270 - FF3 starts 32bit instead of 64bit when both are installed
Summary: FF3 starts 32bit instead of 64bit when both are installed
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: firefox (Show other bugs)
(Show other bugs)
Version: 5.2
Hardware: x86_64 Linux
low
low
Target Milestone: rc
: ---
Assignee: Martin Stransky
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-13 10:31 UTC by Alexander Todorov
Modified: 2009-01-28 09:17 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-28 09:17:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of sh -x firefox (1.79 KB, text/plain)
2008-03-19 13:34 UTC, Alexander Todorov
no flags Details
output of setarch i386 sh -x firefox (1.55 KB, text/plain)
2008-03-19 13:34 UTC, Alexander Todorov
no flags Details

Description Alexander Todorov 2008-03-13 10:31:48 UTC
Description of problem:

Running "firefox" starts the 32bit version instead of the 64bit. ps shows that
/usr/lib/firefox-3.0b4pre/firefox is running.

Further investigation shows that:
$  /usr/lib64/firefox-3.0b4pre/firefox 
Couldn't load XPCOM.


Version-Release number of selected component (if applicable):
firefox-3.0-0.beta3.4.el5

How reproducible:
100%

Steps to Reproduce:
1. Run "firefox"
2. Use ps to check which process is running 32bit or 64 bit

Alternative:
2. Run /usr/lib64/firefox-3.0b4pre/firefox
  
Actual results:
32bit version of program running instead of 64bit. If 32bit is not installed the
program will not start at all.

Expected results:
64bit version starts.

Additional info:
Both 32 and 64 bit packages of FF are installed from the RHEL5.2 beta x86_64 repo.

Comment 1 Alexander Todorov 2008-03-13 10:36:23 UTC
Correction

Actual results:
32bit version of program running instead of 64bit when both are installed. If
32bit is not installed the 64 bit version runs successfully.


Comment 3 Michal Babej 2008-03-14 13:14:05 UTC
I've had firefox-3.0-0.beta3.4.el5, and i've right now updated to snapshot-1
version (beta4.1.el5) on x86_64 system. 

"firefox" launched the 64bit version - worksforme.

If it tried running /usr/lib/firefox-3.0b4pre/firefox, it exited with the same
error (Couldn't load XPCOM.); However if you export MOZ_GRE_CONF correctly it'll
run fine.

I guess your /usr/bin/firefox launching 32b ff is just something misconfigured
on your machine, or rpm multilib fun. You have been experimenting with flash,
right ?

Comment 4 Alexander Todorov 2008-03-14 13:24:57 UTC
I don't think this is related to Flash. When I have both ff.i386 and ff.x86_64
installed the 64bit wouldn't start. same as you had with the 32bit one.

I guess they don't need to be installed both (and 32bit being present mainly
because of flash).

Comment 5 Christopher Aillon 2008-03-15 05:34:02 UTC
Please provide the xulrunner version and arch

Comment 6 Alexander Todorov 2008-03-17 09:37:03 UTC
xulrunner-1.9-0.beta4.1.el5 both i386 and x86_64 are installed

Comment 7 Christopher Aillon 2008-03-17 18:39:25 UTC
/usr/bin/firefox should take care of setting MOZ_GRE_CONF...  

So, you have both 32 and 64 bit xulrunner and only 32bit firefox installed?  Hm,
curious...

Comment 8 Alexander Todorov 2008-03-18 09:51:26 UTC
Christopher,
I had both firefox and xulrunner i386 and x86_64 in the beginning (i.e. when I
filed the bug report). Removing firefox.i386 made it possible for me to run
firefox.x86_64 without getting the error mentioned in comment #0.

Do you need me to retest this on a fresh install and what cases you'd like to
see tested (i.e. what installed and what not)?

Thanks.

Comment 9 Alexander Todorov 2008-03-18 10:58:29 UTC
More info:

1) Install RHEL 5.2 snapshot #1
2) yum install firefox xulrunner (will install both i386 and x86_64 packages)

Version:
firefox-3.0-0.beta4.1.el5
xulrunner-1.9-0.beta4.1.el5

Test results:
$ firefox - starts 64bit FF (check with ps that
/usr/lib64/firefox-3.0b5pre/firefox is running)
$ /usr/lib/firefox-3.0b5pre/firefox - starts 32bit FF without error
$ /usr/lib64/firefox-3.0b5pre/firefox - Couldn't load XPCOM (fails to start)

The results are opposite to comment #0 wrt 64bit not starting when you run
"firefox" but the error "Couldn't load XPCOM" is consistent.

I would suspect there is something wrong because the behavior of binaries under
/usr/$lib_dir/$ff_dir is not the same.

Comment 10 Christopher Aillon 2008-03-18 19:05:33 UTC
Please attach output of:

sh -x firefox
setarch i386 sh -x firefox

Comment 11 Alexander Todorov 2008-03-19 13:34:30 UTC
Created attachment 298506 [details]
output of sh -x firefox

Comment 12 Alexander Todorov 2008-03-19 13:34:57 UTC
Created attachment 298507 [details]
output of setarch i386 sh -x firefox

Comment 13 RHEL Product and Program Management 2008-06-02 20:13:43 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 14 Martin Stransky 2008-06-03 07:55:43 UTC
Taking this one.

Comment 16 RHEL Product and Program Management 2009-01-27 20:41:53 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 17 Christopher Aillon 2009-01-27 22:33:06 UTC
Is this still happening?  It really shouldn't be.  Possibly a corrupt rpmdb?  The output in the attachemnts look correct: on a 64bit machine, running firefox by execs the version in /usr/lib64 and setarch i386 firefox execs the version in /usr/lib ...

Comment 18 Alexander Todorov 2009-01-28 08:30:04 UTC
Can't reproduce. 64bit version starts as expected.

Comment 19 Martin Stransky 2009-01-28 09:17:58 UTC
closing...


Note You need to log in before you can comment on or make changes to this bug.