Bug 437303 - Anaconda crash during ia64 install @ "HP Virtual Mouse"
Anaconda crash during ia64 install @ "HP Virtual Mouse"
Status: CLOSED DUPLICATE of bug 435381
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.2
ia64 Linux
high Severity high
: rc
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-13 10:19 EDT by Prarit Bhargava
Modified: 2008-03-13 10:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 10:55:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prarit Bhargava 2008-03-13 10:19:41 EDT
Description of problem:

While installing, the following crash is seen on the screen:

Installing bootloader...
Found HP Virtual Mouse
Traceback (most recent call first):
  File "/usr/lib/python2.4/site-packages/rhpxl/xhwstate.py", line 749, in
generate_xconfig
    get_option(ilomouse_conf, "MinX").val = 0
  File "/usr/lib/python2.4/site-packages/rhpxl/xserver.py", line 64, in
generateConfig
    self.config = self.hwstate.generate_xconfig(self.mousehw, self.keyboard)
  File "/usr/lib/anaconda/xsetup.py", line 32, in write
    self.xserver.generateConfig()
  File "/usr/lib/anaconda/packages.py", line 117, in writeXConfiguration
    anaconda.id.xsetup.write(fn+"/etc/X11", anaconda.id.mouse, anaconda.id.keyboard)
  File "/usr/lib/anaconda/dispatch.py", line 201, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 124, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/cmdline.py", line 135, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 982, in ?
    anaconda.intf.run(anaconda)
TypeError: Expected a string

install exited abnormally [1/1] 
sending termination signals...done
sending kill signals...done
disabling swap...
        /dev/mapper/VolGroup00-LogVol01
unmounting filesystems...
        /mnt/runtime done


Version-Release number of selected component (if applicable): latest RHEL5
snapshot (20060308)


How reproducible: 100%


Steps to Reproduce:
1. Install.
  
Actual results:

Installing bootloader...
Found HP Virtual Mouse
Traceback (most recent call first):
  File "/usr/lib/python2.4/site-packages/rhpxl/xhwstate.py", line 749, in
generate_xconfig
    get_option(ilomouse_conf, "MinX").val = 0
  File "/usr/lib/python2.4/site-packages/rhpxl/xserver.py", line 64, in
generateConfig
    self.config = self.hwstate.generate_xconfig(self.mousehw, self.keyboard)
  File "/usr/lib/anaconda/xsetup.py", line 32, in write
    self.xserver.generateConfig()
  File "/usr/lib/anaconda/packages.py", line 117, in writeXConfiguration
    anaconda.id.xsetup.write(fn+"/etc/X11", anaconda.id.mouse, anaconda.id.keyboard)
  File "/usr/lib/anaconda/dispatch.py", line 201, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 124, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/cmdline.py", line 135, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 982, in ?
    anaconda.intf.run(anaconda)
TypeError: Expected a string

install exited abnormally [1/1] 
sending termination signals...done
sending kill signals...done
disabling swap...
        /dev/mapper/VolGroup00-LogVol01
unmounting filesystems...
        /mnt/runtime done

Expected results: Install should succeed.


Additional info:  Seen on hp-rx6600-03.rhts.boston.redhat.com . 100% reproducible.
Comment 1 Doug Chapman 2008-03-13 10:55:51 EDT

*** This bug has been marked as a duplicate of 435381 ***

Note You need to log in before you can comment on or make changes to this bug.