Bug 437334 - Lookup channel xmlrpc call does not allow for NULL descriptions
Lookup channel xmlrpc call does not allow for NULL descriptions
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
rhn500-satellite-beta
All Linux
low Severity low
: ---
: ---
Assigned To: Bryan Kearney
Stephen Herr
US=19780
:
: 431288 432086 (view as bug list)
Depends On:
Blocks: 428922 443075
  Show dependency treegraph
 
Reported: 2008-03-13 12:20 EDT by James Bowes
Modified: 2013-01-10 04:57 EST (History)
4 users (show)

See Also:
Fixed In Version: 5.0.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-21 14:43:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Bowes 2008-03-13 12:20:38 EDT
The db allows for NULL descriptions, but lookupchannel doesn't. and so things
will explode when marshalling to xmlrpc. need to say channel.descrption or ""
Comment 1 Amy Owens 2008-03-13 12:49:27 EDT
since this is defined-- moved into accepted backlog
Comment 2 James Bowes 2008-04-15 11:04:54 EDT
*** Bug 431288 has been marked as a duplicate of this bug. ***
Comment 3 James Bowes 2008-04-16 12:41:49 EDT
*** Bug 432086 has been marked as a duplicate of this bug. ***
Comment 4 James Bowes 2008-04-21 08:23:16 EDT
To Test:
 * use sqlplus to find a channel with an empty description, ie
   select * from rhnchannel where description is NULL
 * use rhn-manage-channel to 'list' that channel
   rhn-manage-channel-internal --list --label some-channel
   Details should be displayed, rather than a traceback.
Comment 5 Stephen Herr 2008-04-21 14:43:41 EDT
Looks good in dev, and qa, and stage, and production....

Note You need to log in before you can comment on or make changes to this bug.