Bug 437355 - Wrong language name for norwegian language
Wrong language name for norwegian language
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
A S Alam
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-13 13:22 EDT by Alexander Stevenson
Modified: 2013-07-02 20:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-28 16:25:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexander Stevenson 2008-03-13 13:22:19 EDT
Description of problem:
When selecting language during installation, you are offered one option for 
norwegian language, Norwegian(norsk). The word norsk in paranthesis means 
norwegian in norwegian. When selecting this option you are given the bokmål 
variant of norwegian, which in other distros is usually represented as 
Norwegian(bokmål).

Version-Release number of selected component (if applicable):


How reproducible:
Go through the installation process

Steps to Reproduce:
1.Boot from installation media
2.When asked to select language, browse down to Norwegian(norsk)
3.Select Norwegian(norsk) and complete the installation
  
Actual results:
You are ending up with a Norwegian(bokmål) system.

Expected results:
It doesn't give me any expectation to which variant of norwegian I will get.

Additional info:
It is possible to switch to the other variant of norwegian after the 
installation. This variant is more or less correctly labeled Norwegian, 
Nynorsk(Norway) - Norsk. And in the system-config-language menu, 
Norwegian(bokmål) is labeled Norwegian - Norsk. There is no consistancy here.

It could all be fixed by offering the user two options for norwegian language:
Norwegian(bokmål)
Norwegian(nynorsk)

or alternatively:
Norwegian, Nynorsk
Norwegian, Bokmål
Comment 1 Espen Stefansen 2008-03-13 15:00:59 EDT
Actually, according to ISO 639 [1] it should change to:
Norwegian Bokmål
Norwegian Nynorsk

[1] http://en.wikipedia.org/wiki/List_of_ISO_639-1_codes
Comment 2 Kjartan Maraas 2008-03-13 17:36:08 EDT
Espen is right here. Please change accordingly.
Comment 3 Asgeir Frimannsson 2008-03-14 07:33:38 EDT
+1

This is a bug in anaconda. To be consistent with other languages, this entry [1]
should probably be labeled Norwegian(Bokmål), similar to e.g. Chinese(Traditional).

[1]
http://git.fedorahosted.org/git/anaconda.git?p=anaconda.git;a=blob_plain;f=lang-table;hb=HEAD
Comment 4 Bug Zapper 2008-05-14 02:01:49 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Jeremy Katz 2008-05-28 16:25:13 EDT
Added to git.  We won't add the nyorsk variant at this time, though, due to the
low translation coverage

Note You need to log in before you can comment on or make changes to this bug.