Bug 437371 - anaconda crash in findExistingRootPartitions during install
anaconda crash in findExistingRootPartitions during install
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-03-13 14:39 EDT by Steve Rawlinson
Modified: 2008-03-27 14:23 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-03-27 14:23:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Steve Rawlinson 2008-03-13 14:39:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv: Gecko/20080201 Firefox/

Description of problem:
Anaconda bowls out with an exception at stage one of the installation process with the following message (I'm copying this out by hand s might not be exact):

File /usr/lib/anaconda/partedUtils.py, line 808, in findExistingRootPartitions lvm.vgscan()

Then some calling methods, then

'module' object has no attribute 'vgscan'

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. reboot machine with installation disk in dvd drive, from which it boots
2. follow on-screenn prompts to the 'welcome to fedora' message
3. hit 'OK'
4. (after I tried removing old partitions) get warning that drives need formating
4. Exception message appears.

Actual Results:

Expected Results:

Additional info:
The machine is a HP DL380 with a xeon processor and smart array controller. It has previously had Fedora 7 installed on it (which worked fine). I've tried removing the existing partitions with smart array but get the same error.

I'm using the x86_64 download dvd image for fedora 8.
Comment 1 Chris Lumens 2008-03-14 10:16:50 EDT
Is this better in F9 Alpha?
Comment 2 Steve Rawlinson 2008-03-14 10:24:30 EDT
I haven't tried F9 yet. I'm afraid I'm away for a week now so won't be able to
test that until the 24th.
Comment 3 Steve Rawlinson 2008-03-27 13:42:07 EDT
I have now tied F9, which does not exhibit this error. (I get a different error,
much later in the install process,  which I will report separately).

Note You need to log in before you can comment on or make changes to this bug.