Description of problem:
event-compat-sysv.spec currently contains this:
Provides: SysVinit >= 2.83
Provides: sysvinit >= 2.83
A "Provides" with a >= is a bit odd, but seems to work in rawhide. Nevertheless
it is nearly just as bad as a unversioned provides and could lead to trouble if
we ever want to put a SysVinit package back into the repo. That alone is likely
reason enough to fix this.
But the odd provides also creates problem for older yum/rpm versions, that are
indirectly used together with the rawhide repo if you use mock on older Fedora
or RHEL releases. IOW: the users runs into this problem:
Error: Missing Dependency: SysVinit >= 2.85-38 is needed by package initscripts
I ran into this myself and saw a report in #fedora-devel today from another user
that faced the same problem.
Version-Release number of selected component (if applicable):
The Obsoletes in unversioned as well, which could lead to trouble should we want
to put a sysvinit package into the repo again.
Obsoletes: SysVinit <= 2.86-23
Provides: SysVinit = 2.86
Provides: sysvinit = 2.86
(In reply to comment #0)
> Obsoletes: SysVinit <= 2.86-23
> Provides: SysVinit = 2.86
> Provides: sysvinit = 2.86
That would probably make the package self-obsoleting. I'd suggest this instead:
Obsoletes: SysVinit < 2.86-24, sysvinit < 2.86-24
Provides: SysVinit = 2.86-24, sysvinit = 2.86-24
+1 to comment #1
I'm seeing this on my rhel5/mock builders trying to create f9 buildroots.
(In reply to comment #1)
> That would probably make the package self-obsoleting.
Ohh, yeah, you're right. Sorry for the thinko.
I'll push this tonight.
Fixed in event-compat-sysv-0.3.9-10