Bug 437393 - rsyslog crashes after a couple of "Error adding symbol" errors
Summary: rsyslog crashes after a couple of "Error adding symbol" errors
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rsyslog (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-13 20:12 UTC by Jonathan Kamens
Modified: 2008-03-25 10:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-25 10:03:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2008-03-13 20:12:17 UTC
I see this in /var/log/messages:

Mar 13 15:37:02 jik2 kernel: imklog 3.12.1, log source = /proc/kmsg started.
Mar 13 15:37:02 jik2 kernel: Inspecting /boot/System.map-2.6.23.1-49.fc8
Mar 13 15:37:20 jik2 kernel: Error adding symbol - acpi_os_initialize1.
Mar 13 15:37:20 jik2 kernel: No module symbols loaded - kernel modules not 
enabled.
Mar 13 15:37:20 jik2 kernel: cannot find any symbols, turning off symbol lookups
Mar 13 15:37:20 jik2 rsyslogd: [origin software="rsyslogd" swVersion="3.12.1" x-
pid="23021" x-info="http://www.rsyslog.com"] restart
Mar 13 15:38:02 jik2 kernel: imklog 3.12.1, log source = /proc/kmsg started.
Mar 13 15:38:02 jik2 kernel: Inspecting /boot/System.map-2.6.23.1-49.fc8
Mar 13 15:38:04 jik2 kernel: Error adding symbol - tick_broadcast_on_off.
Mar 13 15:38:04 jik2 kernel: No module symbols loaded - kernel modules not 
enabled.
Mar 13 15:38:04 jik2 kernel: cannot find any symbols, turning off symbol lookups
Mar 13 15:38:04 jik2 rsyslogd: [origin software="rsyslogd" swVersion="3.12.1" x-
pid="23021" x-info="http://www.rsyslog.com"] restart

And then rsyslogd crashes.  I can't find a core file for it anywhere.  Note 
that I have a script running on my machine which sends a HUP signal to rsyslogd 
once per minute.

The last time this happened, rsyslogd had been running for over a day with 
these once-per-minute HUP signals before finally crashing as shown above.  The 
crash before that, it had been running for more than two days before crashing.

The crash always seems to happen shortly after the "Error adding symbol" 
errors, so I assume that they have something to do with the problem, although I 
don't know whether they're a symptom or a cause.  The previous time the crash 
happened, there were also two such errors in the two minutes before the crash, 
and the symbol names complained about in the errors were different.

I checked my rsyslogd process with lsof after it had been restarted several 
times, and I don't see any evidence of a file descriptor leak.  I didn't think 
it likely that that was the cause, since if it were, it seems to me that it 
should crash much sooner than it is, but I thought I should check just in case.

I have rsyslog-3.12.1-1.fc9, and my other packages except for the kernel are up-
to-date with Rawhide.  The kernel is 2.6.23.1-49.fc8.i686.

Therefore, I've told you everything I can about the problem :-).

Comment 1 Peter Vrabec 2008-03-25 10:03:25 UTC
this problem should be solved in rsyslog-3.12.3-1.fc9


Note You need to log in before you can comment on or make changes to this bug.