Bug 437409 - submit.cf.rpmnew created after upgrade
submit.cf.rpmnew created after upgrade
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: sendmail (Show other bugs)
4.6
All Linux
low Severity low
: rc
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-13 17:42 EDT by Matt Seitz
Modified: 2008-08-26 09:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-26 09:44:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Seitz 2008-03-13 17:42:56 EDT
Description of problem:
Upgrading "sendmail" RPM creates unnecessary "/etc/mail/submit.cf.rpmnew"

Version-Release number of selected component (if applicable):

sendmail-8.13.1-3.2.el4

How reproducible:
Always

Steps to Reproduce:
1.  Generate a new "/etc/mail/submit.cf"
2.  rpm -Uhv sendmail

  
Actual results:
RPM version of "submit.cf" saved as "submit.cf.rpmnew"

Expected results:
Just create "submint.mc.rpmnew" if necessary.  Do not try to 
install "submit.cf"

Additional info:
Since "submit.cf" is always regenerated from "submit.mc", there should be no 
need to include a "submit.cf" with the upgrade package.
Comment 1 Phil Knirsch 2008-08-26 09:44:48 EDT
This request was evaluated by Red Hat Engineering for inclusion in a Red
Hat Enterprise Linux maintenance release.

Red Hat does not currently plan to provide this change in a Red Hat Enterprise
Linux update release for currently deployed products.

With the goal of minimizing risk of change for deployed systems, and in
response to customer and partner requirements, Red Hat takes a conservative
approach when evaluating enhancements for inclusion in maintenance updates
for currently deployed products. The primary objectives of update releases
are to enable new hardware platform support and to resolve critical
defects.

However, Red Hat will further review this request for potential inclusion
in future major releases of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.