This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 437429 - Multilib. install corner case error
Multilib. install corner case error
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum (Show other bugs)
5.2
All Linux
high Severity high
: rc
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-13 23:32 EDT by James Antill
Modified: 2010-10-18 10:06 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0388
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:22:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Antill 2008-03-13 23:32:59 EDT
Description of problem:
 This is a weird corner case error we've just found while trying to debug
something else.

 The problem goes like this:

1. You have pkgA-1.x86_64 installed.
2. You want to install PkgBB-7.i386.
3. PkgBB-7 requires libA.so.2
4. libA.so.2 is provided by pkgA-2.i386

...atm. you can reproduce this fairly easily by doing:

. reserve_workflow.py -u <user> -T 24h -S rhts.redhat.com -d RHEL5-Server-U1 -a
x86_64
. register with RHN
. run yum install gtk2.i386

...here pkgA == cups-libs and PkgBB == gtk2. Or the same with enabling of the
Beta channels and installing the new 3.2.8 yum first.

Version-Release number of selected component (if applicable):
 All known yum releases.

 3.0.1 tries to install just the new cups-libs.i386, and so rpm says no because
it won't accept cups-libs-new.i386 and cup-libs-old.x86_64.

 3.2.8 tries to update to just the new cup-libs.x86_64, and so rpm says no
because no cups-libs.i386 is installed at all.
Comment 1 James Antill 2008-03-13 23:52:56 EDT
 We've got a fix, which we think is good, passes all the unit tests etc. and
we've put it into upstream (and so should be in new yum upstream/rawhide release
within a few days).
 So I'd like to propose that we include it in RHEL-5.2

 Pros. for putting this fix into 3.2.8/RHEL-5.2

  . it's a small change
  . it fixes a known problem, with a consistent reproducer.
  . no known regressions on the unit tests.
  . we should see a lot of testing before GA and if anything does go wrong, it's
easy to revert it by GA.

 Cons for not putting the fix into 3.2.8/RHEL-5.2

  . We haven't got this right before, so it's not a regression to just leave it
as a known bug.
  . Public beta has already gone out.
  . It's _possible_ something could go wrong, that we can't forsee that we only
find out about after GA.
Comment 7 James Antill 2008-04-21 10:30:46 EDT
yeh, that looks right.
Comment 10 errata-xmlrpc 2008-05-21 10:22:21 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0388.html
Comment 11 Chris Ward 2008-06-17 11:48:40 EDT
Reminder: This bug includes the 'RHTS' QA Whiteboard Keyword. Don't forget to add
'RHTSdone' to the QA Whiteboard along with a comment describing where the RHTS
test can be found once the RHTS test has been written. Otherwise, if an RHTS
will not be created, please remove RHTS from the qa whiteboard.

Note You need to log in before you can comment on or make changes to this bug.