Bug 437448 - dvipdfmx does not convert eps images by default
dvipdfmx does not convert eps images by default
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tetex (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Jonathan Underwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-14 05:25 EDT by Sarantis Paskalis
Modified: 2008-03-14 11:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-14 08:31:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to enable .eps conversion (1.05 KB, patch)
2008-03-14 05:25 EDT, Sarantis Paskalis
no flags Details | Diff

  None (edit)
Description Sarantis Paskalis 2008-03-14 05:25:36 EDT
Description of problem:
Running dvipdfmx against a dvi file does not convert the referenced .eps images,
producing a blank space.


Version-Release number of selected component (if applicable):
dvipdfmx-0-25.fc8

How reproducible:
Run dvipdfmx  a .tex file which includes a .eps graphic 

Steps to Reproduce:
1. Run dvidpdfx againts a .tex file with a .eps graphic called with
\includegraphics{}
2.
3.
  
Actual results:

sarantis@gallagher:~/Desktop/eap$ dvipdfmx queues.dvi 
queues.dvi -> queues.pdf
[1][2][3][4][5][6][7][8][9
** WARNING ** No image converter available for converting file "./fig1_1.eps" to
PDF format.
** WARNING ** >> Please check if you have 'D' option in config file.
** WARNING ** pdf: image inclusion failed for "fig1_1.eps".
** WARNING ** Failed to read image file: fig1_1.eps
** WARNING ** Interpreting special command PSfile (ps:) failed.
** WARNING ** >> at page="9" position="(176.683, 556.114)" (in PDF)
** WARNING ** >> xxx "PSfile="fig1_1.eps" llx=0 lly=0 urx=594 ury=304 rwi=2551 "


Expected results:
Convert .eps to pdf image.



Additional info:
Problem can be solved by uncommenting the entry in the config file regarding the
conversion of .eps entries for Linux/Unix.  Patch attached.
Comment 1 Sarantis Paskalis 2008-03-14 05:25:36 EDT
Created attachment 298034 [details]
patch to enable .eps conversion
Comment 2 Patrice Dumas 2008-03-14 05:55:48 EDT
Looks like it is solved in devel. Seems that you are using the dvipdfmx
that comes with texlive. In devel dvipdfmx is a stand-alone package 
dvipdfmx-0-0.20.20071115cvs.fc9.i386

Notice that you can't update simply to the newer dvipdfmx since it looks
older than dvipdfmx-0-25.fc8 for rpm (as 25 > 0), you have to remove
and reinstall. Still I am not sure that there is a stand-alone 
dvipdfmx for F8.
Comment 3 Jonathan Underwood 2008-03-14 07:56:09 EDT
Yes, Sarantis is using the tetex bundled dvipdfmx from F-8, so am reassigning
this to tetex. We could consider backporting the separate dvipdfmx from rawhide
to F-8, or we could fix it in the F-8 tetex package. Jindrich - what would you
rather do? 
Comment 4 Sarantis Paskalis 2008-03-14 08:18:09 EDT
I got confused by asking rpm -qf /usr/bin/dvipdfmx which produced the
dvipdfmx-0-25.fc8 result.  Indeed it is built from texlive-2007-25.fc8.src.rpm

So, I guess this is not a distribution-wide bug, but only affects users of
Jindrich's F8 texlive repo.
Comment 5 Jonathan Underwood 2008-03-14 08:30:28 EDT
Oh right!

Jindrich doesn't update his F-8 texlive repo very often. If you want to use
texlive with F-8, I think the way to do that is to enable the development repo,
install the texlive bits, and then disable it again. You'll need to periodically
reenable the development repo to update the texlive bits.

Note though, as Patrice pointed out, with the splitting out of dvipdfmx, you
will need to remove the currently installed dvipdfmx before installing it again
from the development repo (in order to fix up an error with the package
versioning we broke the upgrade path within devel).
Comment 6 Jonathan Underwood 2008-03-14 08:31:55 EDT
Am closing this as RAWHIDE, as it's technically not a bug, but feel free to
discuss any problems you have with this here, and we'll try to help as much as
possible.
Comment 7 Jindrich Novy 2008-03-14 09:14:03 EDT
Just to avoid confusion, the F8 distro is now automagically updated when devel
texlive changes. I've done a couple of scripts to accomplish that. So that a
delay between the new texlive which occur in rawhide and the F8 is a few hours
now. So that if Sarantis updates to the latest texlive in the F8 repo, all
should be fixed.

Sarantis, just please note that I haven't kept the upgrade path for the F8 repo
so you might need to remove the texlive packages completely and install them
again to have everything working as expected.
Comment 8 Jindrich Novy 2008-03-14 09:18:34 EDT
Ok, after closer look I see the dvipdfmx is still built for the F8 but no more
for rawhide. Please update to texlive-2007-27 after few hours and it will be
fixed there.

The name dvipdfmx-0-25.fc8 is ok since there are more packages like dvipng that
lacks the texlive-* prefix because they are standalone utilites with separate
upstream with a plan of separate packaging.
Comment 9 Sarantis Paskalis 2008-03-14 09:24:09 EDT
So, if texlive in F-8 is more or less the same as in devel, dvipdfmx (as an
independent package) needs to be built for F-8 as well, correct?

AFAICS, dvipdfmx (independent) is available only for devel.

Is there any conflict with existing tetex installations in F-8?

P.S. The original problem had a trivial fix (uncommenting an option in a
configuration file)
Comment 10 Jindrich Novy 2008-03-14 09:34:27 EDT
(In reply to comment #9)
> So, if texlive in F-8 is more or less the same as in devel, dvipdfmx (as an
> independent package) needs to be built for F-8 as well, correct?
>

Correct. Jonathan, could we make it in the same way as in case of xdvik?

> AFAICS, dvipdfmx (independent) is available only for devel.
> 

Right. Releasing dvipdfmx for F8 should fix it.

> Is there any conflict with existing tetex installations in F-8?

It shouldn't since the new dvipdfmx will simply have a greater NVR what should
safely upgrade your actual texlive dvipdfmx. In case you find some, they will be
resolved by releasing the new texlive to the F8 repo this afternoon.

> 
> P.S. The original problem had a trivial fix (uncommenting an option in a
> configuration file)

Yup. In any case it makes sense to move all dvipdfmx stuff to the package it
actually belong to ;-)
Comment 11 Jonathan Underwood 2008-03-14 11:48:01 EDT
(In reply to comment #10)
> (In reply to comment #9)
> > So, if texlive in F-8 is more or less the same as in devel, dvipdfmx (as an
> > independent package) needs to be built for F-8 as well, correct?
> >
> 
> Correct. Jonathan, could we make it in the same way as in case of xdvik?
> 

We can do that, but we'd then need to remove dvipdfmx from the F8 tetex packages. 

An alternative would be for you to build dvipdfmx (and the other split out
components) in your F8 texlive repository.

I don't mind either way, your call.





Note You need to log in before you can comment on or make changes to this bug.