Bug 437468 - dos.c:624 in function probe_partition_for_geom() failed [NEEDINFO]
dos.c:624 in function probe_partition_for_geom() failed
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: parted (Show other bugs)
5.1
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: Joel Andres Granados
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-14 09:12 EDT by Mohammed Maati
Modified: 2008-11-05 10:54 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-05 10:54:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dcantrell: needinfo? (riadmin)


Attachments (Terms of Use)
This is the exception details generated by Anaconda when it crashes and before it reboots the server. (924.27 KB, text/plain)
2008-03-14 09:15 EDT, Mohammed Maati
no flags Details
This is the output of the following commands: "fdisk -l", "lspci" and "lspci -n". (7.01 KB, text/plain)
2008-03-14 17:15 EDT, Mohammed Maati
no flags Details
Attached is the output of dmidecode if it can be of any help. Thanks. (31.62 KB, text/plain)
2008-03-19 10:32 EDT, Mohammed Maati
no flags Details

  None (edit)
Description Mohammed Maati 2008-03-14 09:12:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.12) Gecko/20080201 Red Hat/1.5.0.12-0.10.el4 Firefox/1.5.0.12 pango-text

Description of problem:
Bad: The program simply will not work. It stops and reboots when it tries to partition the virtual disk.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Run the a network installation through NFS.
2. Ignore the errors and keep going with the installation.
3. After you choose the packages to install, the program stops and reboots when it tries to partition the virtual disk.

Actual Results:
The program stops and reboots when it tries to partition the virtual disk.

Expected Results:
Partition the virtual disk and install the OS packages.

Additional info:
Comment 1 Mohammed Maati 2008-03-14 09:15:10 EDT
Created attachment 298045 [details]
This is the exception details generated by Anaconda when it crashes and before it reboots the server.
Comment 2 David Cantrell 2008-03-14 14:10:16 EDT
Can you provide an 'fdisk -l' output of the disk you are trying to install to?
Comment 3 Mohammed Maati 2008-03-14 17:15:05 EDT
Created attachment 298082 [details]
This is the output of the following commands: "fdisk -l", "lspci" and "lspci -n".
Comment 4 Mohammed Maati 2008-03-19 10:32:34 EDT
Created attachment 298517 [details]
Attached is the output of dmidecode if it can be of any help.
Thanks.


Attached is the output of dmidecode if it can be of any help.

Thanks.
Comment 5 Joel Andres Granados 2008-06-10 08:26:36 EDT
ok, this might be parted or pyparted.  

Does this happen if you don't use nfs installs?
What errors did you ignore?  where did you see them?
What resulting partition scheme. (its relevant to test parted and pyparted)
Can you create the partitions on that disk you were going to install on with
parted in a running environment?
Comment 6 Joel Andres Granados 2008-11-05 10:48:22 EST
Its been quite some time since the last comment in this bug.  I'm going to devel nack it, thinkig that the reporter just lost interest.

If someone still experiences this issue please reopen and attach the first 1024 bytes of the disk in question.  Also try to answer to the questions in comment #5 is relevant.
Comment 7 RHEL Product and Program Management 2008-11-05 10:54:12 EST
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.