Bug 437496 - libdlm copies lvb from bad address
libdlm copies lvb from bad address
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: David Teigland
GFS Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-14 12:05 EDT by David Teigland
Modified: 2009-04-16 19:03 EDT (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2008-0347
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:58:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Teigland 2008-03-14 12:05:07 EDT
Description of problem:

When a program does a lock operation that reads an lvb, libdlm
copies the lvb data from a bogus location instead of from the
proper offset in the buffer it just read.  The location of the
lvb data is calculated wrongly due to a missing cast.

This causes a segfault in the program.  This was introduced by
the libdlm changes that went into 5.2.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2008-03-18 11:30:30 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 5 David Teigland 2008-03-20 13:33:19 EDT
pushed to RHEL5 branch 1bb513e542a4ca7f3e79f5000b0bb0783a41b0b5
Comment 7 Dean Jansa 2008-03-27 11:19:27 EDT
With this patch I am able to read/write lvbs without issue.
Comment 9 errata-xmlrpc 2008-05-21 11:58:56 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0347.html

Note You need to log in before you can comment on or make changes to this bug.