Bug 437623 - Rawhide installation fails on JS20/JS21
Rawhide installation fails on JS20/JS21
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-15 07:31 EDT by Adrian Reber
Modified: 2008-04-27 07:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-27 07:09:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrian Reber 2008-03-15 07:31:49 EDT
On JS20/JS21 (ppc64) with SLOF-1.4.0-0
(http://www.ibm.com/developerworks/power/pa-slof/) anaconda no longer detects
the network card correctly. It used to work in Fedora 8.

Anaconda says "no driver found" and selecting the tg3 driver manually does not help.
Comment 1 Jeremy Katz 2008-03-16 13:09:08 EDT
Does udev normally work for getting the module loaded?
Comment 2 Adrian Reber 2008-03-16 17:03:43 EDT
It is a PCI card:

02:04.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5780S Gigabit
Ethernet (rev 10)
02:04.1 Ethernet controller: Broadcom Corporation NetXtreme BCM5780S Gigabit
Ethernet (rev 10)

This seems to be a problem with the kernel. I just built a 2.6.25-rc5 with the
driver built-in and I get following error:

tg3.c:v3.87 (December 20, 2007)
PCI: Device 0001:02:04.0 not available because of resource collisions
tg3: Cannot enable PCI device, aborting.
tg3: probe of 0001:02:04.0 failed with error -22
PCI: Device 0001:02:04.1 not available because of resource collisions
tg3: Cannot enable PCI device, aborting.
tg3: probe of 0001:02:04.1 failed with error -22

So this is probably not an anaconda bug.
Comment 3 Chuck Ebbert 2008-03-18 13:46:41 EDT
What kernel version was used for that test? 
Comment 4 Adrian Reber 2008-03-18 14:03:42 EDT
As mentioned above: 2.6.25-rc5

Concerning this I already received an answer from Nathan Lynch and he wrote:

Yes, this is a known issue... Ben and I have looked at it some, but no
fix yet.  According to a git bisect the change that caused it is "Merge
PCI resource allocation &
assignment" (3fd94c6b1a1158d3e0e505b0a00c3a707b5fcd40) but I don't
think this would be easy to revert.
Comment 5 Chuck Ebbert 2008-04-26 21:03:03 EDT
Still broken?
Comment 6 Adrian Reber 2008-04-27 07:09:20 EDT
Changes in Linux exposed a bug in the firmware. With correct firmware the
installation can detect the network card again. Closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.