Bug 437657 - USB card reader does not work
USB card reader does not work
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-15 16:34 EDT by Pavel Rosenboim
Modified: 2008-06-16 23:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 23:03:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel messages log (32.71 KB, text/plain)
2008-03-15 16:34 EDT, Pavel Rosenboim
no flags Details
usbmon log (459.02 KB, text/plain)
2008-03-15 16:35 EDT, Pavel Rosenboim
no flags Details

  None (edit)
Description Pavel Rosenboim 2008-03-15 16:34:24 EDT
Description of problem:
I have some generic USB combo hub + card reader. Under linux, I'm unable to
mount any card I tried. According to dmesg output, after I insert a card into
reader, kernel periodically resets it. This happens in both F7 latest kernel and
in latest rawhide kernel.

Version-Release number of selected component (if applicable):
kernel-2.6.23.17-82.fc7
kernel-2.6.25-0.101.rc4.git3.fc9

How reproducible:
Always.

USB log and messages log attached
Comment 1 Pavel Rosenboim 2008-03-15 16:34:24 EDT
Created attachment 298162 [details]
kernel messages log
Comment 2 Pavel Rosenboim 2008-03-15 16:35:57 EDT
Created attachment 298163 [details]
usbmon log
Comment 3 Pete Zaitcev 2008-03-15 20:34:05 EDT
This is a very good log, thanks. Unfortunately, I don't know what to do
about this. The device works fine at first and reports missing media.
Then, just out of the blue, it stops replying to the request to transfer
the 13-byte status block (it's the -84: EILSEQ: 3-try token timeout
or CRC error). This is a low-level USB protocol violation,
which should never happen. After that the device performs all control
transations, accepts SCSI commands, but (mostly) fails on getting
responses just like before. It's possible that it becomes this way
when a card is inserted.

Maybe it wants a delay before a status request, I don't know. The
longest gap before the failing transfer is 9ms.

I would also try a CF card. Maybe the internal firmware gets into
a loop when it has to run bit-bang control for serial interface
carts.

In any case, clearly something is buggy here, we're looking for
workarounds.
Comment 4 Pavel Rosenboim 2008-03-16 02:41:20 EDT
Actually, it was a CF card. Other cards - SD and M2 - behave the same way. 
Comment 5 Pavel Rosenboim 2008-03-16 13:47:56 EDT
Just tried it in Ubuntu 7.10 liveCD and it works there(kernel
2.6.22-14-generic). Only getting few I/O errors during large file copy.
Comment 6 Pete Zaitcev 2008-03-16 16:24:01 EDT
Maybe they applied US_FL_GO_SLOW and it worked, who knows. It's a major
pain to liberate fixes hidden in Ubuntu.
Comment 7 Bug Zapper 2008-05-14 11:22:58 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bug Zapper 2008-06-16 23:03:50 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.