Bug 437678 - (TBb9d8707e) TBb9d8707e Conf.py:1016:__setitem__:NameError: global name 'join' is not defined
TBb9d8707e Conf.py:1016:__setitem__:NameError: global name 'join' is not defined
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
8
All Linux
low Severity urgent
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
: 434935 435202 438332 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-16 05:42 EDT by Adrin Jalali
Modified: 2008-04-22 18:39 EDT (History)
5 users (show)

See Also:
Fixed In Version: 1.5.5-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 18:39:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
system-config-network stack trace. (1.56 KB, text/plain)
2008-03-16 05:42 EDT, Adrin Jalali
no flags Details
patch (318 bytes, patch)
2008-03-22 04:52 EDT, Eddy Setyawan
no flags Details | Diff
system-config-network bug report (1.56 KB, text/plain)
2008-03-26 16:27 EDT, Ivan Virgili
no flags Details
log (1.41 KB, text/plain)
2008-03-28 22:33 EDT, Eddy Setyawan
no flags Details
crash in ipsec module (731 bytes, text/plain)
2008-03-29 06:52 EDT, Eddy Setyawan
no flags Details
crash in host module (1.21 KB, text/plain)
2008-03-29 06:58 EDT, Eddy Setyawan
no flags Details

  None (edit)
Description Adrin Jalali 2008-03-16 05:42:17 EDT
Description of problem:
I have installed this package :
http://linux.dell.com/files/ubuntu/modem-drivers/hsf-custom/hsfmodem-7.68.00.06tst1oem-1.i386.rpm
for my connexant modem, while installing, I saw some conflict with my sound
module, but after reboot, system-config-network crashes whenever I click the
save button and the attached file is the stack trace.

system-config-network-1.4.7-1.fc8
Comment 1 Adrin Jalali 2008-03-16 05:42:17 EDT
Created attachment 298181 [details]
system-config-network stack trace.
Comment 2 Harald Hoyer 2008-03-22 04:38:08 EDT
*** Bug 438332 has been marked as a duplicate of this bug. ***
Comment 3 Eddy Setyawan 2008-03-22 04:52:38 EDT
Created attachment 298825 [details]
patch
Comment 4 Adrin Jalali 2008-03-22 05:05:40 EDT
I myself uninstalled the rpm package and downloaded and installed the tar.gz
file from this address :
http://linux.dell.com/files/ubuntu/modem-drivers/hsf-custom/hsfmodem-7.68.00.06tst1oem.tar.gz
and everything goes right. I think the default rpm is configed for older
versions of alsa. That's why the default package works on ubuntu, which has
older version of alsa by now.
Comment 5 Eddy Setyawan 2008-03-22 05:14:03 EDT
the problem is not the hsf rpm package, but it's a bug in system-config-network
component, u can apply the patch I've submit before 
if you don't want to wait next update release u can try to patch it by your self

cd /usr/share/system-config-network/netconfpkg/conf
patch -p0 < /location/of/patch/file.patch
Comment 6 Ivan Virgili 2008-03-26 16:27:39 EDT
Created attachment 299224 [details]
system-config-network bug report

I am having the same problem.
I will try to apply the patch manually.
At the same time, I am attaching the bug report.
Comment 7 Ivan Virgili 2008-03-26 16:31:42 EDT
Patch work fine. Thanks..
Comment 9 Harald Hoyer 2008-03-26 21:58:39 EDT
*** Bug 435202 has been marked as a duplicate of this bug. ***
Comment 10 Eddy Setyawan 2008-03-28 22:33:49 EDT
Created attachment 299558 [details]
log
Comment 11 Harald Hoyer 2008-03-29 06:29:57 EDT
(In reply to comment #10)
> Created an attachment (id=299558) [edit]
> log
> 
should be fixed in:
http://people.fedoraproject.org/~harald/downloads/system-config-network/1.5.92/
Comment 12 Eddy Setyawan 2008-03-29 06:52:44 EDT
Created attachment 299566 [details]
crash in ipsec module
Comment 13 Eddy Setyawan 2008-03-29 06:58:49 EDT
Created attachment 299567 [details]
crash in host module

It's crash when saving after add second line, no problem in first line adding
with save process
Comment 14 Harald Hoyer 2008-03-31 07:02:08 EDT
*** Bug 434935 has been marked as a duplicate of this bug. ***
Comment 15 Harald Hoyer 2008-03-31 07:07:05 EDT
(In reply to comment #13)
> Created an attachment (id=299567) [edit]
> crash in host module
> 
> It's crash when saving after add second line, no problem in first line adding
> with save process   

ok.. moved over to bug #439770
Comment 16 Fedora Update System 2008-04-07 10:34:43 EDT
system-config-network-1.5.5-1.fc8 has been submitted as an update for Fedora 8
Comment 17 Fedora Update System 2008-04-09 01:20:03 EDT
system-config-network-1.5.5-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-network'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2995
Comment 18 Fedora Update System 2008-04-22 18:38:50 EDT
system-config-network-1.5.5-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.