Bug 437696 - IPV6 Misconfiguration Causes Network Sluggishness
IPV6 Misconfiguration Causes Network Sluggishness
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-16 12:24 EDT by Randy Yates
Modified: 2008-03-31 12:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-31 12:01:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randy Yates 2008-03-16 12:24:00 EDT
Description of problem:

The symptoms of the problem were, in general, sluggish network performance:

  1. Slow yum updates/installs
  2. "Page Not Found" errors on common sites such as google
  3. excruciatingly slow smtp and pop3 mail server interaction

I'm not certain, but I suspect that the networking configuration files
in /etc/sysconfig/networking/... weren't properly configured with
regards to ipv6, which should default to off I believe. Since this is
a fairly fresh installation of Fedora 8 (about two weeks old), I
suspect it was a problem either in the installation itself or in one
of the subsequent yum updates. The installation is Fedora Respin
20080204.

Simply going to system-config-network app, selecting the active
profile under the Devices tab, and pressing the Edit button seemed
to restore the misconfigured parameters and the network immediately 
began to function normally.

Version-Release number of selected component (if applicable):

n/a

How reproducible:

Don't know - didn't "reinstall" 

Steps to Reproduce:
1. Install Fedora Respin 20080204
2. Check a few well-known web sites (under Firefox) for
Page Not Founds or otherwise sluggish behavior.
3. Attempt to connect to a pop3 or other mail server and
obvserve behavior.
  
Actual results:


Expected results:


Additional info:

Linux localhost.localdomain 2.6.24.3-12.fc8 #1 SMP Tue Feb 26 14:21:30 EST 2008
x86_64 x86_64 x86_64 GNU/Linux
Comment 1 Randy Yates 2008-03-16 12:31:14 EDT
Note that the checkbox for "Enable IPv6 configuration for this interface" was
unchecked even the first time I edited the profile. I'm guessing that the code
rewrites the configuration parameters when the (profile) "Edit" dialog is exited. 
Comment 2 Harald Hoyer 2008-03-31 05:45:46 EDT
well, I think you can turn on/off IPv6 in anaconda (the installer). Maybe you
forgot to turn off IPv6.

So this may be a bug of anaconda, not s-c-network (which fixed it)
Comment 3 Randy Yates 2008-03-31 06:53:07 EDT
ok Harold, i'm sorry but this whole thing may have been a farce. i found out
some time after creating this bug report that there was a severe problem with
roadrunner's dns nameservers in the Raleigh, NC area. After switching to 4.2.2.4
and 4.2.2.5, the problem TOTALLY went away. 

it may have been that doing the ipv6 thing did really help some (i.e., that this
was a dual problem of both an ipv6 issue AND the roadrunner dns's), or it may
have been that the perceived improvement (after ipv6 changes) was really false. 

sorry for being so ambiguous, but i believe being truthful makes it easier for
everyone. 
Comment 4 Jeremy Katz 2008-03-31 12:01:21 EDT
It's possible that they were more broken with giving back ipv6 response codes. 
That's happened with TWC in the past.

Note You need to log in before you can comment on or make changes to this bug.