Bug 437751 - Unable to correctly install a Xen guest with more than 9 partitions on xvda
Unable to correctly install a Xen guest with more than 9 partitions on xvda
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: Chris Lumens
Alexander Todorov
: Patch
Depends On:
Blocks: 391501
  Show dependency treegraph
 
Reported: 2008-03-17 04:44 EDT by Andrew Ryan
Modified: 2010-10-22 19:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:32:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kickstart script to reproduce the problem (1.40 KB, text/plain)
2008-03-17 04:44 EDT, David Robinson
no flags Details
proposed patch (667 bytes, patch)
2008-03-17 04:46 EDT, David Robinson
no flags Details | Diff

  None (edit)
Description David Robinson 2008-03-17 04:44:47 EDT
Description of problem:
The installation of Red Hat Enterprise Linux 5.1 as a paravirt guest doesn't
work correctly if more than 9 partitions are created during installation. The
installation completes, but upon first reboot the user will be placed into
maintenance mode because filesystems on /dev/xvda[10-15] cannot be found. The
filesystems on devices /dev/xvda[10-15] were not created correctly during
installation because the device nodes were incorrect.

The commands below were run during installation. Note the minor device numbers.
sh-3.1# ls /dev/xvda*
brw------- 1 root 0 202, 0 Mar 17 16:09 /dev/xvda
brw------- 1 root 0 202, 1 Mar 17 16:03 /dev/xvda1
brw------- 1 root 0 202, 1 Mar 17 16:03 /dev/xvda10
brw------- 1 root 0 202, 1 Mar 17 16:03 /dev/xvda11
brw------- 1 root 0 202, 1 Mar 17 16:03 /dev/xvda12
brw------- 1 root 0 202, 1 Mar 17 16:03 /dev/xvda13
brw------- 1 root 0 202, 1 Mar 17 16:03 /dev/xvda14
brw------- 1 root 0 202, 2 Mar 17 16:03 /dev/xvda2
brw------- 1 root 0 202, 3 Mar 17 16:03 /dev/xvda3
brw------- 1 root 0 202, 4 Mar 17 16:03 /dev/xvda4
brw------- 1 root 0 202, 5 Mar 17 16:03 /dev/xvda5
brw------- 1 root 0 202, 6 Mar 17 16:03 /dev/xvda6
brw------- 1 root 0 202, 7 Mar 17 16:03 /dev/xvda7
brw------- 1 root 0 202, 8 Mar 17 16:03 /dev/xvda8
brw------- 1 root 0 202, 9 Mar 17 16:03 /dev/xvda9
sh-3.1# e2label /dev/xvda5
/test5
sh-3.1# e2label /dev/xvda6
/test4
sh-3.1# e2label /dev/xvda7
/test3
sh-3.1# e2label /dev/xvda8
/test2
sh-3.1# e2label /dev/xvda9
/test1
sh-3.1# e2label /dev/xvda10
/boot
sh-3.1# e2label /dev/xvda11
/boot
sh-3.1# e2label /dev/xvda12
/boot
sh-3.1# e2label /dev/xvda13
/boot
sh-3.1# e2label /dev/xvda14
/boot
sh-3.1# e2label /dev/xvda15

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux 5.1
anaconda-11.1.2.87-1

How reproducible:
100%

Steps to Reproduce:
1. install a guest using the kickstart script attached (which creates additional
partitions)
  
Actual results:
Filesystems aren't created on /dev/xvda[10-15] because of incorrect devices.
Filesystems on /dev/xvda[1-9] are OK.

Expected results:
Filesystems are created on /dev/xvda[1-15].

Additional info:
Attached is a patch that may correct the problem. It hasn't been tested yet.
Comment 1 David Robinson 2008-03-17 04:44:48 EDT
Created attachment 298238 [details]
kickstart script to reproduce the problem
Comment 2 David Robinson 2008-03-17 04:46:57 EDT
Created attachment 298239 [details]
proposed patch
Comment 3 David Robinson 2008-03-17 04:48:56 EDT
You will need to uncomment the partition details in the kickstart script...
Comment 5 Denise Dumas 2008-04-15 14:51:36 EDT
Changing the partitioning code requires extensive retesting, and it's too late
in the 5.2 release for this change. We're about to close Snapshot 6 of 8, so
this unfortunately has to move to 5.3. 
Comment 7 RHEL Product and Program Management 2008-06-12 16:28:25 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 9 Chris Lumens 2008-06-17 13:16:33 EDT
This patch will be included in the next build of anaconda, though we need to
make sure nothing else is required to make this work.
Comment 15 errata-xmlrpc 2009-01-20 16:32:57 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0164.html

Note You need to log in before you can comment on or make changes to this bug.