From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/4.0; Linux) KHTML/4.0.2 (like Gecko) Fedora/4.0.2-10.fc9
Description of problem:
When I run tclsh and enter command "package require BLT", I have the error
message "version conflict for package"Tcl": have 8.5.1, need exactly 8.5".
This bug render all tcl applications which need BLT option fail to run because
when a application check the availability of BLT by the command "package
require BLT", a failure code return.
I guess the trouble is in libBLTlite24.so. Somehow, the pacth level must be 0!
The corresponding rpm blt-2.4-25.fc9.i386.rpm should be rebuild.
Version-Release number of selected component (if applicable):
tcl/tk 8.5.1 ; blt 2.4 ; libBLTlite24.so
Steps to Reproduce:
2.package require BLT"
version conflict for package "Tcl": have 8.5.1, need exactly 8.5
Bug confirmed and reassigned to owner.
This is due to a mismatch between the value of TCL_VERSION provided by the tcl
build configuration file, and the version reported by 'package provide' in Tcl.
I'm not sure if this should be considered a bug in the core Tcl package, but
I've added a patch to blt to avoid this problem in the future. I'll close this
bug once the package has built in Rawhide.