Bug 437781 - Saving / Opening of files now longer works
Saving / Opening of files now longer works
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: liferea (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marc Wiriadisastra
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-17 09:25 EDT by Sindre Pedersen Bjørdal
Modified: 2008-03-18 17:10 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 09:36:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sindre Pedersen Bjørdal 2008-03-17 09:25:25 EDT
Description of problem:
Since the upgrade to rawhide, saving and opening files from rss feeds which
provides files, such as mp3 podcasts, no longer works. 

Opening an mp3 file from an mp3 podcast in Liferea by pressing the save/open
button and choosing open file does open the default player for such files, in my
case totem, but it shows an error about location not being found. 

Choosing to save the file instead, gives me the save as dialog, but after
choosing the location and pressing save, nothing seems to happen and no file
appears in the chosen location. 

Version-Release number of selected component (if applicable):
liferea-1.4.12-2.fc9.i386

How reproducible:
Every Time

Steps to Reproduce:
1. Add an mp3 podcast feed to liferea, such as
http://www.npr.org/rss/podcast.php?id=5

2. Update the feed in liferea
 
3. Try to open or download one of the files provided by the feed
  
Actual results:
Does not open the file and unable to save the file.

Expected results:
Opening and saving should "just work"
Comment 1 Marc Wiriadisastra 2008-03-18 05:09:35 EDT
Can you try with the latest version which has been uploaded.
Comment 2 Sindre Pedersen Bjørdal 2008-03-18 06:16:12 EDT
Problem persist with 1.2.13-1, nothing seems to have changed with regards to
this bug.
Comment 3 Marc Wiriadisastra 2008-03-18 09:34:44 EDT
I have just tested this using 1.4.12-2 and I can not verify this bug. Have you
got the correct mp3 codecs?

I think that is your issue. I'm running kde and it works fine.
Comment 4 Marc Wiriadisastra 2008-03-18 09:36:43 EDT
I'm going to resolve this as worksforme without more info since all I've got is
that it doesn't work yet it does for me.
Comment 5 Sindre Pedersen Bjørdal 2008-03-18 13:58:50 EDT
Here's the relevant output from debug-all liferea session: 

"
GUI: launch URL: false  true 0
CACHE:
url:http://podcastdownload.npr.org/anon.npr-podcasts/podcast/35/88350952/npr_88350952.mp3,
type:mp3 mime:FALSE
UPDATE: downloading
http://podcastdownload.npr.org/anon.npr-podcasts/podcast/35/88350952/npr_88350952.mp3
to /home/foolish/Nedlastinger/npr_88350952.mp3...
UPDATE: running "wget -q -O '/home/foolish/Nedlastinger/npr_88350952.mp3'
'http://podcastdownload.npr.org/anon.npr-podcasts/podcast/35/88350952/npr_88350952.mp3'"
Cannot specify -r, -p or -N if -O is given.
Bruk: wget [FLAGG]... [URL]...
UPDATE: running "totem '/home/foolish/Nedlastinger/npr_88350952.mp3'"
TRACE: + feedlist_auto_update
TRACE: - feedlist_auto_update
TRACE: + feedlist_auto_update
TRACE: - feedlist_auto_update
GUI: launch URL: false  true 0
UPDATE: downloading
http://podcastdownload.npr.org/anon.npr-podcasts/podcast/35/88350952/npr_88350952.mp3
to /home/foolish/npr_88350952.mp3...
UPDATE: running "wget -q -O '/home/foolish/npr_88350952.mp3'
'http://podcastdownload.npr.org/anon.npr-podcasts/podcast/35/88350952/npr_88350952.mp3'"
Cannot specify -r, -p or -N if -O is given.
Bruk: wget [FLAGG]... [URL]...
TRACE: + feedlist_auto_update
TRACE: - feedlist_auto_update
TRACE: + on_quit
"

Turns out the problem is wget. I have timestamping always turned on in my
.wgetrc, which breaks liferea downloads all of a sudden. I'll talk to upstream,
feel free to close this one as notabug.
Comment 6 Sindre Pedersen Bjørdal 2008-03-18 14:03:32 EDT
Setting downloading to use curl instead of wget in the enclosures tab in
preferences makes it work again btw.

Note You need to log in before you can comment on or make changes to this bug.