Bug 437783 - Error in rhn-kickstart on rhel 5
Error in rhn-kickstart on rhel 5
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Partha Aji
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-17 09:39 EDT by James Bowes
Modified: 2013-01-10 04:57 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-13 13:43:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Bowes 2008-03-17 09:39:47 EDT
provisioning against webqa with a rhel 5 machine i get the following traceback
from rhn-kickstart:

Traceback (most recent call last):
  File "/usr/sbin/rhn_check", line 273, in __run_action
    (status, message, data) = CheckCli.__do_call(method, params)
  File "/usr/sbin/rhn_check", line 266, in __do_call
    retval = method(*params)
  File "/usr/share/rhn/actions/kickstart.py", line 21, in initiate
    static_device=static_device, preserve_files=preserve_files)
  File "/usr/share/rhn/rhnkickstart/kickstart.py", line 51, in initiate
    base_dir)
  File "/usr/share/rhn/rhnkickstart/common.py", line 17, in download_install_ima
ges
    remote_path, local_path)
  File "/usr/share/rhn/rhnkickstart/common.py", line 98, in _download_install_im
ages
    except urllib.HTTPError, e:
exceptions.AttributeError: 'module' object has no attribute 'HTTPError'

Which stops my kickstart.

this is with rhn-kickstart version 2.0.10-4.el5
Comment 1 Brandon Perkins 2009-01-13 13:43:23 EST
Cannot reproduce with rhn-kickstart-2.0.10-10.el5.noarch.  Please provide more details if you can reproduce it, with specifics on system profile configuration, distribution used, and kickstart profile in hosted.

Note You need to log in before you can comment on or make changes to this bug.