Bug 437793 - RFE: please apply genfs_context nfs_t to lustre and panfs
RFE: please apply genfs_context nfs_t to lustre and panfs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-17 10:20 EDT by Stephan Wiesand
Modified: 2008-05-21 12:07 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0465
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 12:07:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephan Wiesand 2008-03-17 10:20:25 EDT
Description of problem:

It would help if the lustre and panfs filesystems would be handled as nfs, afs
etc. are:
 - automounting would work
 - users could mv files into them

Since this can't be done in a policy module, please consider adding

genfscon lustre / gen_context(system_u:object_r:nfs_t,s0)
genfscon panfs / gen_context(system_u:object_r:nfs_t,s0)

to filesystem.te .

Thanks.
Comment 1 Daniel Walsh 2008-03-17 11:10:54 EDT
Not sure this will get into U2 policy.

Fixed in selinux-policy-2.4.6-126.el5

Comment 7 errata-xmlrpc 2008-05-21 12:07:26 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0465.html

Note You need to log in before you can comment on or make changes to this bug.