Bug 437884 - lighttpd does not provide "httpd"
lighttpd does not provide "httpd"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lighttpd (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-17 17:21 EDT by Ed Marshall
Modified: 2008-03-22 17:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-22 17:55:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Marshall 2008-03-17 17:21:47 EDT
This is more a point of query, rather than a bug: should the lighttpd RPM
provide "httpd"? This came up after noticing that packages such as trac and
gallery2 require httpd, but apparently only because of the inclusion of an
/etc/httpd/conf.d configuration file. Because lighttpd can't parse those files,
however, perhaps it shouldn't advertise such a capability.

Alternatively, this might be more appropriate filed as a bug against those
packages (trac and gallery2 are the ones I know of off the top of my head,
there's probably others) in that a webserver-specific sample configuration file
shouldn't necessarily taint the whole package. At least several other packages
have solved this problem through splitting off httpd-specific portions
(subversion has "subversion" vs "mod_dav_svn"; php has "php-cli" vs. "php", etc).

Would appreciate advice on the best way to move forward.
Comment 1 Matthias Saou 2008-03-18 08:21:08 EDT
First thing : A package should NEVER provide another package's name. So lighttpd
will never, EVER, provide "httpd", as this would cause many breakage.

IIRC, lighttpd used to provide "webserver", which was something that could be
easily required by any package needing a web server to be useful. I'm not sure
why, but that provides is no longer there. I could put it back if required, but
it wouldn't entirely solve your problem.

The problem here is probably about parent directory ownership, as the Fedora
packaging guidelines state that these should be met by the package's
requirement, so to get /etc/httpd/conf.d/ owned, "httpd" is required.

Possible solutions :
- Have the Fedora guidelines allow for "dangling" apache config bits.
- Split the apache config bits in sub-packages, where the "httpd" requirement
would also go.

Maybe there are others. In all cases, not much to do with lighttpd itself...
Comment 2 Matthias Saou 2008-03-22 17:55:05 EDT
I've added :
Provides: webserver
to the lighttpd package in devel. Anything else needs to be done outside of
lighttpd, sorry.

Note You need to log in before you can comment on or make changes to this bug.