Bug 437890 - rhythmbox --print-playing spawns a second rb
rhythmbox --print-playing spawns a second rb
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
: 438711 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-17 18:21 EDT by Dave Jones
Modified: 2015-01-04 17:30 EST (History)
3 users (show)

See Also:
Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-28 06:26:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2008-03-17 18:21:50 EDT
Description of problem:
If I run rhythmbox --print-playing, I get two rb icons in the notification area.
 The rhythmbox-client process never quits, and doesn't print anything to stdout.

The first instance of rb is playing music just fine, and isn't blocking.
The second instance that starts up is fully usable, will play tunes etc, even
whilst the first one continues.

Version-Release number of selected component (if applicable):
rhythmbox-0.11.3-7.fc8
Comment 1 Bastien Nocera 2008-03-17 21:33:55 EDT
Any errors on the command-line? Are you running within a session that has a dbus
daemon running (look for "/bin/dbus-daemon --session" in the process list)
Comment 2 Dave Jones 2008-03-18 17:09:37 EDT
Starting up the first rhythmbox from command line gets me..

(rhythmbox:7527): Rhythmbox-WARNING **: Failed to invoke RequestName: Connection
":1.22" is not allowed to own the service "org.gnome.Rhythmbox" due to SELinux
policy

(rhythmbox:7527): Rhythmbox-WARNING **: Got unhandled reply 52 from RequestName

(rhythmbox:7527): Rhythmbox-WARNING **: Unable to start mDNS browsing: MDNS
service is not running

(rhythmbox:7527): Rhythmbox-WARNING **: Unable to notify network of music
sharing: The avahi MDNS service is not running

Comment 3 Dave Jones 2008-03-18 17:10:20 EDT
hmm, I seem to have two dbus daemons present. is that normal ?

$ ps ax | grep dbus-daemon |  grep session
 1109 ?        Ssl    0:00 /bin/dbus-daemon --fork --print-pid 4 --print-address
7 --session
 7604 ?        S      0:00 /bin/dbus-daemon --fork --print-pid 4 --print-address
7 --session
Comment 4 Dave Jones 2008-03-18 17:11:21 EDT
the second one starts up when I run the rhythmbox-client command.
Comment 5 Bastien Nocera 2008-03-18 18:00:36 EDT
Not normal unless $DBUS_SESSION_BUS_ADDRESS is unset in your session, somehow.
Or SELinux is being a pain.
Comment 6 Bastien Nocera 2008-03-24 14:23:58 EDT
*** Bug 438711 has been marked as a duplicate of this bug. ***
Comment 7 Bastien Nocera 2008-03-24 14:26:18 EDT
What did you change in the SELinux policy in F8 that makes the session D-Bus
reject connections? (Bug 438711 has the full D-Bus error message)
Comment 8 Daniel Walsh 2008-03-25 17:08:55 EDT
Nothing.  Are you seeing AVC messages in /var/log/audit/audit.log?  Does this
work with SELinux in permissive mode.

Comment 9 Bastien Nocera 2008-03-26 07:10:04 EDT
(In reply to comment #8)
> Nothing.  Are you seeing AVC messages in /var/log/audit/audit.log?  Does this
> work with SELinux in permissive mode.

It works in permissive mode (as mentioned in bug 438711).

Dave, Peter, could you please give the full AVC message from the logs when this
happens?
Comment 10 Peter Janakiev 2008-03-26 08:52:48 EDT
Mar 26 14:49:14 localhost dbus: avc:  received setenforce notice (enforcing=1)
Mar 26 14:49:31 localhost dbus: avc:  denied  { acquire_svc } for
service=org.gnome.Rhythmbox spid=21417
scontext=unconfined_u:system_r:unconfined_execmem_t:s0-s0:c0.c1023
tcontext=unconfined_u:system_r:unconfined_t:s0-s0:c0.c1023 tclass=dbus
--
type=USER_AVC msg=audit(1206535944.921:199): user pid=1762 uid=81
auid=4294967295 subj=system_u:system_r:system_dbusd_t:s0 msg='avc:  denied  {
send_msg } for msgtype=method_call interface=org.freedesktop.Avahi.Server
member=GetAPIVersion dest=org.freedesktop.Avahi spid=21521 tpid=1928
scontext=unconfined_u:system_r:unconfined_execmem_t:s0-s0:c0.c1023
tcontext=system_u:system_r:avahi_t:s0 tclass=dbus : exe="/bin/dbus-daemon"
(sauid=81, hostname=?, addr=?, terminal=?)'
type=USER_AVC msg=audit(1206535944.933:200): user pid=1762 uid=81
auid=4294967295 subj=system_u:system_r:system_dbusd_t:s0 msg='avc:  denied  {
send_msg } for msgtype=method_call interface=org.freedesktop.Avahi.Server
member=GetAPIVersion dest=org.freedesktop.Avahi spid=21521 tpid=1928
scontext=unconfined_u:system_r:unconfined_execmem_t:s0-s0:c0.c1023
tcontext=system_u:system_r:avahi_t:s0 tclass=dbus : exe="/bin/dbus-daemon"
(sauid=81, hostname=?, addr=?, terminal=?)'
Comment 11 Dave Jones 2008-03-27 19:52:16 EDT
I can no longer reproduce this since I last rebooted.
Comment 12 Daniel Walsh 2008-03-28 06:26:41 EDT
Fixed in selinux-policy-3.0.8-95.fc8
Comment 13 Bastien Nocera 2008-03-28 12:32:48 EDT
Thanks Dan!

Note You need to log in before you can comment on or make changes to this bug.