Bug 437942 - "pfmon -t 20 --system-wide" cause segment fault
"pfmon -t 20 --system-wide" cause segment fault
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pfmon (Show other bugs)
5.2
ia64 Linux
high Severity high
: rc
: ---
Assigned To: William Cohen
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-18 07:08 EDT by Song, Youquan
Modified: 2009-06-19 22:46 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:23:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Song, Youquan 2008-03-18 07:08:43 EDT
Description of problem:

Run "pfmon -t 20 --system-wide" , it cause segment fault.
 
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.pfmon -t 20 --system-wide
2.
3.
  
Actual results:
Segment fault:

<pfmon fatal error @ [5762:5764] ip=0x40000000000a7ad0 addr=0x80>
with libunwind installed, you could get a call stack here!
pfmon got a fatal SIGSEGV signal
<pfmon fatal error @ [5762:5767] ip=0x40000000000a7ad0 addr=0x80>
with libunwind installed, you could get a call stack here!
<pfmon fatal error @ [5762:5763] ip=0x40000000000a7ad0 addr=0x80>
pfmon got a fatal SIGSEGV signal
<pfmon fatal error @ [5762:5765] ip=0x40000000000a7ad0 addr=0x80>
Segmentation fault


Expected results:


Additional info:
Comment 1 Geoff Gustafson 2008-03-18 13:24:28 EDT
Youquan, please describe the hardware you're getting this result on.
Comment 2 Song, Youquan 2008-03-18 21:44:04 EDT
Sorry. The bug was found on the platform: Hitach, with 2 Montvale CPUs.
Comment 3 Luming Yu 2008-03-19 23:12:42 EDT
Tested the pfmon shipped with rhel 5.2 beta (3.2) on two different box with two
different kernel (one is -84, another is 2.6.25-rc3), Both segment fault exactlly!

Tested with pfmon 3.3-alpha , the test case just works well..
So the rhel 5.2 pfmon utility should be synced up with pfmon upstream..
Comment 4 Luming Yu 2008-04-07 05:00:54 EDT
any update on the bug?
Comment 5 Luming Yu 2008-04-07 10:22:19 EDT
Youquan,
probably we need a IT opened for this bug too.

Thanks,
Luming
Comment 6 Song, Youquan 2008-04-07 22:13:47 EDT
I will do it after validate on RHEL5.2 snapshot4, because the the 
pfmon/oprofile feature will update on snapshot4.
Comment 7 Song, Youquan 2008-04-15 03:37:00 EDT
This bug is not fixed at RHEL5.2 snapshot4 which include pfmon 32. It need to 
update to pfmon 3.2-alpha to work round.
Comment 8 William Cohen 2008-04-17 16:54:53 EDT
What ia64 platform was this on? There are different code paths used depending
whether this is montecito or an older Itanium 2.
Comment 9 Luming Yu 2008-04-20 23:23:00 EDT
I reproduced the problem on tiger4 with montecito.
Since pfmon 3.3-alpha just works, I'm just asking for directly upgrading to
pfmon 3.3-alpha for fixing this problem.I didn't try to dig out how the problem
got fixed in 3.3-alpah. Please let me know your plan on this bug.

Thanks,
Luming
Comment 10 Luming Yu 2008-04-24 04:33:40 EDT
Is this bug going to be fixed inl 5.2?
Comment 12 Gary Case 2008-04-29 10:53:11 EDT
It's too late to include this in 5.2, but I've asked if we can address it in 5.3.
Comment 13 RHEL Product and Program Management 2008-06-02 16:13:21 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 14 William Cohen 2008-07-11 10:22:01 EDT
Could you include the results of "rpm -q pfmon libpfm" for the pfmon and libpfm
that are causing the crash? When attempting to replicate the problem on a local
ia64 machine running RHEL 5 I couldn't reproduce the crash.
Comment 15 Luming Yu 2008-07-11 10:43:11 EDT
#rpm -q pfmon libpfm
pfmon-3.2-0.060926.4.el5
libpfm-3.2-0.060926.4.el5
#cat /etc/redhat-release
Red Hat Enterprise Linux Server release 5.2 (Tikanga)
Comment 17 William Cohen 2008-09-03 15:39:15 EDT
Same underlying issue as rhbz #231095.

*** This bug has been marked as a duplicate of bug 231095 ***
Comment 18 John Villalovos 2008-09-03 16:18:37 EDT
Re-opening bug since we have no access to Bug #231095 and can't see status on it to see if it is fixed or not.
Comment 19 Frank Ch. Eigler 2008-09-23 10:35:26 EDT
The bug is fixed with the update that will come out with RHEL5.3 beta+.
pfmon-3.2-0.060926.5.el5.  Please check it when able.
Comment 21 Petr Šplíchal 2008-10-03 10:15:51 EDT
Bug reproduced, fix verified in new version on ia64 arch.

pfmon-3.2-0.060926.4.el5
:: [   PASS   ] :: Testing sleep 3
:: [   PASS   ] :: Testing ls /tmp
:: [   PASS   ] :: Testing ls /tmp -e L3_MISSES
:: [   FAIL   ] :: Testing --system-wide
:: [   FAIL   ] :: Testing -t 20 --system-wide
:: [   FAIL   ] :: Testing --system-wide -e L3_MISSES
:: [   PASS   ] :: Testing --long-show-events='CPU.*CYCLE.*'
:: [   PASS   ] :: Testing -i nops_retired

pfmon-3.2-0.060926.5.el5
:: [   PASS   ] :: Testing sleep 3
:: [   PASS   ] :: Testing ls /tmp
:: [   PASS   ] :: Testing ls /tmp -e L3_MISSES
:: [   PASS   ] :: Testing --system-wide
:: [   PASS   ] :: Testing -t 20 --system-wide
:: [   PASS   ] :: Testing --system-wide -e L3_MISSES
:: [   PASS   ] :: Testing --long-show-events='CPU.*CYCLE.*'
:: [   PASS   ] :: Testing -i nops_retired

Not moving to VERIFIED yet, we'll wait for Partner feedback to confirm that the fix works for them.
Comment 22 Chris Ward 2008-11-28 02:13:19 EST
Partners, this bug should be fixed in the latest RHEL 5.3 Snapshot. We believe that you have some interest in its correct functionality, so we're making a friendly request to send us some testing feedback. 

If you have a chance to test it, please share with us your findings. If you have successfully VERIFIED the fix, please add PartnerVerified to the Bugzilla keywords, along with a description of the results. Thanks!
Comment 23 Song, Youquan 2008-11-28 03:23:49 EST
PartnerVerified. I test on Hitachi Montvale, the bug as fixed RHEL5.3 Beta.
Comment 25 errata-xmlrpc 2009-01-20 16:23:20 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0147.html

Note You need to log in before you can comment on or make changes to this bug.