Bug 437990 - switch to man-db project
switch to man-db project
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: man (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
http://www.nongnu.org/man-db/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-18 11:52 EDT by Stepan Kasal
Modified: 2008-05-12 04:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-12 04:59:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stepan Kasal 2008-03-18 11:52:01 EDT
There are two forks of the man program available.
John W. Eaton, who started writing the man program back in 1990 and 1991, kind
of recommends man-db (http://www.nongnu.org/man-db/), see
http://article.gmane.org/gmane.comp.sysutils.autoconf.general/10236/match=man-db+versions+two

BTW, Debian and SuSE distributions do use man-db instead of man-1*.tar.
Comment 1 Stepan Kasal 2008-05-12 04:20:36 EDT
I should have writen some reasons:

man-db uses Berkeley db instead of text file for the index of man pages, so
searching for man pages with whatis (man -k) anmd apropos (man -f) shall be
quicker.  This sounds nice, but it is not a strong reason, as I have never heard
about any performance problems with these commands.

man-db uses autotools, and consequently has better support for GNU coding
standards, and is more portable to non-Linux systems.  The former might help us
with packaging in the long run, but it not so important when we have man-1.6x
well domesticated in our spec file.  The latter (portability) is not directly
relevant here.

man-db seems to be kind of popular: Debian (incl. Ubuntru) and SuSE has selected
it as their only man implementation.  OTOH, Mandrike has the old one, as we
have, and Gentoo provides ebuilds for both.

To sum up, there seems to be no strong reason for man-db, co my cry "switch to"
was not justified.
OTOH, I think we should remember man-db as a possible alternative.  If man-db
becomes dominant in the future, we might decide to "go with the crowd," but it
is not so at the moment.
Comment 2 Ivana Varekova 2008-05-12 04:59:53 EDT
Thanks for your justification, for now I leave Federico Lucifredi's man in
fedora,  if there is any new fact/reason to change the upstream, please reopen
this bug and add a comment here.

Note You need to log in before you can comment on or make changes to this bug.