Bug 437999 - cyrus-imapd should not include lm_sensors-devel in BuildRequires
cyrus-imapd should not include lm_sensors-devel in BuildRequires
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cyrus-imapd (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Michal Hlavinka
Brian Brock
:
Depends On: 437819
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-18 12:31 EDT by Karel Volný
Modified: 2011-07-21 08:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-21 06:33:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2008-03-18 12:31:39 EDT
Description of problem:
current version of cyrrus-imapd has dependency on lm_sensors-devel which 
causes rebuild failure on non-x86 platforms where lm_sensors-devel is not 
available
(this is workarounded in Brew by fake provides)

Version-Release number of selected component (if applicable):
cyrus-imapd-2.3.7-2.el5

How reproducible:
always

Steps to Reproduce:
1. rpmbuild --rebuild cyrus-imapd-2.3.7-2.el5.src.rpm
  
Actual results:
error: Failed build dependencies:
        lm_sensors-devel is needed by cyrus-imapd-2.3.7-2.el5.ppc64

Expected results:
package rebuilds correctly without the need to install lm_sensors-devel on 
platforms where it is not available

Additional info:
lm_sensors-devel is needed to rebuild correctly on x86 systems with SNMP 
support, however this package should be required by net-snmp-devel which is 
buildrequired by cyrus-imapd, see bug #437819
Comment 1 RHEL Product and Program Management 2008-07-21 19:04:47 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 10 RHEL Product and Program Management 2009-11-06 13:51:00 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 11 Karel Volný 2009-11-09 04:02:48 EST
proposing for the next version; the bug this depends on was fixed recently
Comment 14 RHEL Product and Program Management 2010-08-09 14:42:35 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 17 RHEL Product and Program Management 2011-01-11 16:12:10 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 18 RHEL Product and Program Management 2011-01-11 17:26:28 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 22 errata-xmlrpc 2011-07-21 06:33:11 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1075.html
Comment 23 errata-xmlrpc 2011-07-21 08:19:31 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1075.html

Note You need to log in before you can comment on or make changes to this bug.