Bug 438004 - I/O error messages when upgrading from 5.1 GA Client to 5.2
I/O error messages when upgrading from 5.1 GA Client to 5.2
Status: CLOSED DUPLICATE of bug 368821
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
5.1
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Peter Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-18 13:13 EDT by Alexander Todorov
Modified: 2008-03-26 16:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-26 16:41:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2008-03-18 13:13:24 EDT
Description of problem:
While upgrading RHEL Client from 5.1 GA to 5.2 I get these messages while
installing the new kernel:

  Updating  : cairo                        ##################### [188/526] 
  Installing: kernel                       ##################### [189/526] 
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
Buffer I/O error on device fd0, logical block 0
end_request: I/O error, dev fd0, sector 0
Buffer I/O error on device fd0, logical block 0
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
Buffer I/O error on device fd0, logical block 0
end_request: I/O error, dev fd0, sector 0
Buffer I/O error on device fd0, logical block 0
  Updating  : hwdata                       ##################### [190/526]

Version-Release number of selected component (if applicable):
kernel-2.6.18-85.el5.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Install RHEL Client 5.1 GA
2. Update to the latest 5.2 client via yum
  
Actual results:
I/O errors in yum output

Expected results:
No errors

Additional info:
Doesn't seem that the new kernel is broken.
Comment 2 Prarit Bhargava 2008-03-19 09:45:38 EDT
From RHKL -- this appears to be a grub issue where grub is attempting to access
a floppy drive that doesn't exist.

P.
Comment 3 Prarit Bhargava 2008-03-20 11:08:26 EDT
One of these is from mkinitrd or more specifically, nash.

echo nash-resolveDevice LABEL=/ | /sbin/nash --forcequiet

results in a 

end_request: I/O error, dev fd0, sector 0

on systems without a floppy.
Comment 4 Prarit Bhargava 2008-03-20 11:24:43 EDT
Actually two of these are from nash-resolveDevice, and the other is from grubby.

See mkinitrd and new-kernel-pkg.

P.
Comment 5 Peter Jones 2008-03-26 16:41:13 EDT

*** This bug has been marked as a duplicate of 368821 ***

Note You need to log in before you can comment on or make changes to this bug.