Bug 438099 - (Torbutton_Addon) 2fer - Bookmarks not diplaying; and Bookmark Organizer/History Manager (Library) are not functioning.
2fer - Bookmarks not diplaying; and Bookmark Organizer/History Manager (Libra...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-18 22:05 EDT by Robert Gray
Modified: 2008-03-19 18:01 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-19 18:01:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Scrnshot of Library (16.95 KB, image/png)
2008-03-18 22:05 EDT, Robert Gray
no flags Details
Non-reproduction (206.81 KB, image/png)
2008-03-19 12:02 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Robert Gray 2008-03-18 22:05:49 EDT
Greetings, Ladies and Geeks - this one's a two-fer:

Description of problems:
1) Bookmarks don't get displayed. - I get a smidgin (.5mm? wide) of what may be 
the first branch of the menu selection-tree texbox. 

2) When "Bookmarks>Organize Bookmarks or "History>Show All History" is selected 
from the Menu Bar, a Library Window Opens. 

The Library Window appears to host the History/Bookmark functions, but appears 
to be completely nonfunctional as in:
-no history is displayed
-no bookmarks are displayed (even "new" ones)
-preexistent bookmarks (before this latest update) are gone 
-unable to import bookmarks from Opera nor from an html file
-unable to export...since nothing's displayed - (Bada-Bing!)

Version-Release number of selected component (if applicable):
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5pre) Gecko/2008031714 Fedora/
3.0-0.44.cvs20080315.fc9 Minefield/3.0b5pre

How reproducible:
Try to use Bookmarks and History
  
Actual results:
See above

Expected results:
Something that at least displays some data - I know this is Alpha (and you're 
rushing to make the Beta Release Deadline), folks; but someone should have 
walked though the basic functional parameters before releasing this.

IMHO - if uncorrected, it would impact the adoption of the Beta version of FC9.
if it can't be fixed in time, I recommend directing users to to other browsers, 
such as:
Epiphany (in repo) or 
Opera - their FC8 version works on this version

Regards
Comment 1 Robert Gray 2008-03-18 22:05:49 EDT
Created attachment 298470 [details]
Scrnshot of Library
Comment 2 Matěj Cepl 2008-03-19 12:02:36 EDT
Created attachment 298531 [details]
Non-reproduction

cannot reproduce here

Reporter, is there anything interesting and special about your system? Any
special plugins (try to reproduce with -safe-mode to firefox)? Are you able to
reproduce with firefox from
ftp://ftp.mozilla.org/pub/firefox/releases/3.0b4/linux-i686 ? Could you try to
move ~/.mozilla somewhere out of the way -- is the issue still reproducable?
Comment 3 Robert Gray 2008-03-19 16:09:23 EDT
Greetings Matej:

<WEARING ASS-HAT MODE>
My apologies for jumping to conclusions on this one - I walked through your 
troubleshooting protocols (downloading b4 and trying regular and safe modes for 
b4/b5 - couldn't find ".mozilla" though); and encoutered various degrees of the 
Library Window and Bookmark functional capabilities. Most of it worked in the 
safe mode.

By furthering the process of elimination, it would appear that the TorButton 
Add-on is causing the entries to disappear on 3.0b4/b5. Disabling that Add-on 
brought everything back to "normal" per se.

I'll drop a line with the Torbutton crew.

Owe you guys one - give me a call if you need a keyboard-trained mammal to do 
some more UAT.

</WEARING ASS-HAT>

Regards


 


(In reply to comment #2)
> Created an attachment (id=298531) [edit]
> Non-reproduction
> 
> cannot reproduce here
> 
> Reporter, is there anything interesting and special about your system? Any
> special plugins (try to reproduce with -safe-mode to firefox)? Are you able to
> reproduce with firefox from
> ftp://ftp.mozilla.org/pub/firefox/releases/3.0b4/linux-i686 ? Could you try to
> move ~/.mozilla somewhere out of the way -- is the issue still reproducable?

Comment 4 Matěj Cepl 2008-03-19 18:01:11 EDT
OK, then it is apparently NOTABUG (meaning, not our bug).

Note You need to log in before you can comment on or make changes to this bug.