Bug 438157 - Thinkpad t/x61: Several FN-Keys without any function
Summary: Thinkpad t/x61: Several FN-Keys without any function
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 5.1
Hardware: All Linux
high
high
Target Milestone: rc
: ---
Assignee: John Feeney
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 391501
TreeView+ depends on / blocked
 
Reported: 2008-03-19 14:07 UTC by Alan Matsuoka
Modified: 2018-10-20 01:12 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-25 16:47:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xmodmap output (16.96 KB, application/octet-stream)
2008-03-19 14:07 UTC, Alan Matsuoka
no flags Details

Description Alan Matsuoka 2008-03-19 14:07:11 UTC
Description of problem:
The following FN-Keys are not working with the T61 or x61:

Version-Release number of selected component (if applicable):

RHEL 5.1. xorg-x11-drv-i810

How reproducible:


Steps to Reproduce:
FN+F2 : Lock
FN+F3 : Battery State
FN+F5 : Radio control
FN+F8 : Track Point Settings, Mouse Settings?
FN+F9 : Eject
ThinkVantage

  
Actual results:

Function keys stopped working. The events aren't getting generated.

Expected results:
Function keys should work.

Additional info:

Comment 1 Alan Matsuoka 2008-03-19 14:07:12 UTC
Created attachment 298516 [details]
xmodmap output

Comment 2 Alan Matsuoka 2008-03-19 15:49:19 UTC
This problem seems to be related to bz 249400. The keys obviously do not produce
a scan code.

As LVM is planning to roll out laptops starting at the end of march, this is
quite urgent.

Comment 7 RHEL Product and Program Management 2009-03-11 17:39:10 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.


Note You need to log in before you can comment on or make changes to this bug.