Bug 438235 - Red Hat Cert fails on eth0 network test
Red Hat Cert fails on eth0 network test
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
other All
low Severity high
: ---
: ---
Assigned To: Greg Nichols
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-19 15:56 EDT by IBM Bug Proxy
Modified: 2008-07-16 17:59 EDT (History)
1 user (show)

See Also:
Fixed In Version: hts-5.2-16.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-20 13:11:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Network Log File (3.34 KB, text/plain)
2008-03-19 15:56 EDT, IBM Bug Proxy
no flags Details
SOS Report for QS22 (414.41 KB, application/octet-stream)
2008-03-19 15:56 EDT, IBM Bug Proxy
no flags Details
HTS Plan for QS22 (1.32 KB, text/xml)
2008-03-19 15:56 EDT, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 43233 None None None Never

  None (edit)
Description IBM Bug Proxy 2008-03-19 15:56:46 EDT
---Problem Description---
Ran the latest Red Hat Hardware Cert package(hts-5.2-4.el5) on Cell QS22 Blade
and it failed the network test for eth0.  QS22 Blades are diskless systems which
require NFSroot through eth0 device.  This was ran on a RHEL5.2 Beta release.

When I ran the test, I tested eth1 and eth0, eth1 passed fine with no errors. 
Because the filesystem was not mounted via eth1,  I answered "y" to the
following question:
"The test will shutdown and restore interface eth1, is this OK? (y|n)"

For eth0, I answered "n" because the NFSroot was mounted via eth0. 
Consequently, it failed with the following message:

mount -o rw,intr,rsize=12288,wsize=12288,udp lewis7:/var/hts/export
/tmp/tmppkmsHQnfsdir
Traceback (most recent call last):
  File "./network.py", line 564, in ?
    returnValue = networkTest.do(sys.argv)
  File "/usr/share/hts/lib/hts/test.py", line 226, in do
    return self.run()
  File "./network.py", line 541, in run
    returnValue = self.nfsTest()
  File "./network.py", line 441, in nfsTest
    os.system("rm -rf %s/%s" % (self.nfsdir, self.ipAddress))
AttributeError: NetworkTest instance has no attribute 'ipAddress'

I will attach the log file for more info.
 
---uname output---
2.6.18-84.el5
 
Machine Type = BladeCenter QS22
 
---Steps to Reproduce---
run:
hts --test network certify --server cell4.ltc.austin.ibm.com

Bug Severity raised to high as eth0 needs to pass HTS
Comment 1 IBM Bug Proxy 2008-03-19 15:56:49 EDT
Created attachment 298577 [details]
Network Log File
Comment 2 IBM Bug Proxy 2008-03-19 15:56:53 EDT
Created attachment 298578 [details]
SOS Report for QS22
Comment 3 IBM Bug Proxy 2008-03-19 15:56:55 EDT
Created attachment 298579 [details]
HTS Plan for QS22
Comment 4 Greg Nichols 2008-03-19 21:07:47 EDT
Fixed HTS 5.2 R6
Comment 5 IBM Bug Proxy 2008-03-26 13:56:41 EDT
------- Comment From hannsj_uhl@de.ibm.com 2008-03-26 13:51 EDT-------
Hello Red Hat,
when can we expect the updated hts test suite for our use ..?
At ftp://partners.redhat.com/a166eabc5cf5df158922f9b06e5e7b21/hwcert/noarch/
the latest version is still hts-5.2-4.el5 ..
Please advise.
Thanks for your support.
Comment 6 John Jarvis 2008-03-27 15:25:46 EDT
An updated HTS test suite is available at 
http://people.redhat.com/ltroan/fixes/hts/test/

Please test and provide feedback.
Comment 7 IBM Bug Proxy 2008-03-28 00:57:00 EDT
------- Comment From lxie@us.ibm.com 2008-03-28 00:49 EDT-------
(In reply to comment #12)
> ------- Comment From jjarvis@redhat.com 2008-03-27 15:25 EST-------
> An updated HTS test suite is available at
> http://people.redhat.com/ltroan/fixes/hts/test/
>
> Please test and provide feedback.

Abe, please try the latest hts above and close the bug if the problem is fixed.

thanks,

Linda
Comment 8 IBM Bug Proxy 2008-03-28 19:16:55 EDT
------- Comment From abareval@us.ibm.com 2008-03-28 19:08 EDT-------
Hello,
I attempted hts package from http://people.redhat.com/ltroan/fixes/hts/test/ on
RHEL5.2 Snap2 and the network tests now passed on both eth1 and eth0.
Comment 9 IBM Bug Proxy 2008-03-31 11:56:54 EDT
------- Comment From hannsj_uhl@de.ibm.com 2008-03-31 11:50 EDT-------
closing bugzilla per previous comment ...
Comment 11 Hao Liu 2008-06-18 02:15:25 EDT
Abe, 
  would you please provide a already setup environment for testing? Thank you.
Comment 12 IBM Bug Proxy 2008-06-18 15:41:06 EDT
------- Comment From abareval@us.ibm.com 2008-06-18 15:37 EDT-------
(In reply to comment #17)
> ------- Comment From hliu@redhat.com 2008-06-18 02:15 EST-------
> Abe,
> would you please provide a already setup environment for testing? Thank you.

Hello,
We have closed this Bug on IBM's side, QS22 Blades have now been RHEL Certified,
not sure what further info you're looking for?
Comment 13 Hao Liu 2008-06-18 21:57:32 EDT
Abe,
  I need to confirm the bug has been fixed, we don't have an environment as you
described, so it'll be great if you can provide such an environment for testing,
thank you.
Comment 14 Lawrence Lim 2008-06-20 13:11:00 EDT
Resolving due to lack of hardware for verification.
Comment 15 IBM Bug Proxy 2008-06-23 08:00:54 EDT
------- Comment From markwiz@us.ibm.com 2008-06-23 07:59 EDT-------
there is a QS22 working in Raleigh. Scott Dodson has it in his bladecenter
because it was the only model in Raleigh that can work with the QS22.

Note You need to log in before you can comment on or make changes to this bug.