Bug 438250 - aalib 1.4.0-0.14.rc5 breaks aalib-config --libs
aalib 1.4.0-0.14.rc5 breaks aalib-config --libs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: aalib (Show other bugs)
rawhide
All Linux
urgent Severity high
: ---
: ---
Assigned To: Garrick Staples
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-19 17:13 EDT by Ville Skyttä
Modified: 2008-03-24 23:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-24 23:59:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2008-03-19 17:13:01 EDT
Changes in aalib 1.4.0-0.14.rc5 have broken aalib-config --libs; it now returns
a whole slew of -lfoo things for which the devel package lacks foo-devel
dependencies for.  This will break builds of dependent packages as can be
witnessed eg. in
http://koji.fedoraproject.org/koji/getfile?taskID=522783&name=build.log

$ aalib-config --libs
-laa -lm -lX11 -lgpm -lslang -lncurses

One "fix" would be to add dependencies to libX11-devel, gpm-devel, slang-devel
and ncurses-devel to aalib-devel, but that seems very much like linkage bloat -
I think it'd be fine if "aalib-config --libs" would just output "-laa" and
nothing else as no static libs are shipped.  No need to add any new dependencies
to aalib-devel that way.

1.4.0-0.13.rc5 did not have this problem.  Setting high priority and severity
because this is currently blocking a xine-lib security update for Rawhide.
Comment 1 Garrick Staples 2008-03-24 23:59:07 EDT
aalib-config is now patched to only have the -laa.

Note You need to log in before you can comment on or make changes to this bug.